Your Questions Regarding the Legacy Business Support Forums
cancel
Showing results for 
Search instead for 
Did you mean: 

Extrenal links in forum messages

David Balažic
Frequent Advisor

Extrenal links in forum messages

Hi!

The links in messages are going through some javascript, so they don't work for opening in new window or tab (middle button click).

Can this be please fixed ?

When a message has several links, it very annoying to not be able to simply open them all in new tabs, like with normal links.

Regards,
David
18 REPLIES
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

Here is an example http://www.google.com
Rainald T
Honored Contributor

Re: Extrenal links in forum messages

David,
which broser is this about?

I checked your sample in IE7.
Although my system in general is having troubles in opening a new tabbed page in an open IE window when called from another program, the middle button (mouse wheel) as well as right-click and selecting "open new tabbed page" work fine.

Rainald
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

FireFox 2.0.0.1 :
- middle click : new empty tab
- control + left click : new empty tab
- shift + left click : new empty window

IE 6:
- right click and "Open in New Window" : new window with an error message "Cannot find server or DNS Error"

This I tried right now. I also tried over weekend on another PC with IE7 and it did not work there either.
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

I just tried IE7:
- middle click : opens in new window
- right click and "Open in New Window" : opens in new window
- right click and "Open in New Tab" : opens in new window (instead of tab)
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

And Opera v9.10
- middle click : new empty tab
- right click and "Open" : just a message about a blocked popup
- right click and "Open in new window" : new empty window
- right click and "Open in new tab" : new empty tab
Rainald T
Honored Contributor

Re: Extrenal links in forum messages

David,
thanks fo rthe feedack.

I only have IE7 and IE6.
Unless a link is broken or misspelled or ended with a ".", "," or the like, right-click and context menu works for me under both version. And middle-button click works in IE7 too.

So it seems that it must a very special link this is about.
Would you mind a sample for a link not working?

Rainald

David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

I already did in my second post here.
Rainald T
Honored Contributor

Re: Extrenal links in forum messages

Sorry, David, for having overlooked it.

Tested it again, no problems.

As the link reads:
"javascript:openExternal('http://www.google.com')" could it be the other browsers (except) IE7 are having troubles in working with JavaSript?
Did you check the security settings?

With IE7 it might be the settings under "Tools | Internet options .."

Rainald
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

They all have default settings and they work just fine on the other web sites, I can open every link as I want.

If HP wants they links to be a PIA, fine.
My life is too short to waste time for issues like this.


Rainald T
Honored Contributor

Re: Extrenal links in forum messages

David,
not be taken the wrong the way:
*I* myself have nothing at all to do with HP.

I'm nothing more than another user like you are.

Rainald

David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

Sorry, I mistakenly thought this is somehow an offical HP support forum.
Gary Cantwell
Honored Contributor

Re: Extrenal links in forum messages

Hi David,

We have an enhancement request raised to address this issue,

Cheers,

Gary
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

That's great !

Thanks for listening.

David
Rainald T
Honored Contributor

Re: Extrenal links in forum messages

Gary,
do you think that there would be a problem in so far??

Rainald
P.S. As I might have your ear: There are quite some unanswered questions of mine waitin for your attention ...
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

testing : http://www.google.com
ah, still the same...
Rainald T
Honored Contributor

Re: Extrenal links in forum messages

No problem with the link on my side with IE7.
A new tabbed page is opened as ist should be.

Rainald
David Balažic
Frequent Advisor

Re: Extrenal links in forum messages

Strange, on my IE7 it does not.
Rainald T
Honored Contributor

Re: Extrenal links in forum messages

David,
as said before:
I'd suspect the security settings in IE.

Rainald