Aruba & ProVision-based
Showing results for 
Search instead for 
Did you mean: 

Re: Aruba 3810m - ip ssh public-key (not working)

Go to solution
Occasional Contributor

Aruba 3810m - ip ssh public-key (not working)

I am configuring my new set of Aruba switches in a stack, and after getting the stack upgraded to KB.16.02.0009 and stacked I like to set up authentication via SSH keys.  Normally on the HE e3800 I use a file that I can tftp over in this manner:

copy tftp pub-key-file pubkeys_mine manager
000M Download failed: invalid key in key file.

 Not so fast....that doesn't work with these Arubas.  Next I tried to use this command to load them in one at a time:

 # ip ssh public-key manager 'ssh-rsa AAAAB3NzaC1yc2EAAAADAQ
 Invalid key.

Again not working.  The guide indicates that this should work.  Can anyone tell me what exactly is wrong with my keys or perhaps the form of the command I am using? 

Occasional Contributor

Re: Aruba 3810m - ip ssh public-key (not working)

Using only the keys listed one per line in a file worked for the HP e3800, but the Aruba requires single quotes and a comment at the end of the line.  This way:

'ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQC7ZSzrPN+zUadGg1BK72vZcM9GlCMKHDdh0+CM/c/KgpKvMNTy2SxDQJ9W0Z/Id5hZ2i3OLCCZ8xBnEEgqBzxg/OTgNj+5jxm3Z5Jnxsq8MUaHa3t3u+tm0GbLPQsBba2CeOviLGW/WMyrDfgVs1cROy6py+yN3I6qJuI9iBxP49/P/xa+7QISQ/MZwHxjBP0xCSJj8GmEUAApb4cb5DYOenIkQBFPXrd2dK1v1THnmgi8pLURkT7auolUHdIDInusSvTYhbzlI0yQT/kuj6BEmOuPz5879XsyDkAQ7NDuuNhX5JFoiHP5CRE0a/jv47ERTl+kcPEdpGRfo9pAcPjz paul@rackspace'

You must format each line that way, and then you can use the TFTP method to load in the keys.  This is not mentioned in the access and security guide.

Honored Contributor

Re: Aruba 3810m - ip ssh public-key (not working)

Good catch!

Maybe providing some documentation feedback to HPE would be great: see here.

Probably you were referring to May 2016 updated releases of: