Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP ProCurve 5400 and Netware servers

 
SOLVED
Go to solution
Highlighted
Valued Contributor

HP ProCurve 5400 and Netware servers

Hello,
our customer is installing Procurve 5400 and 3500 switches, but he has some problems "to see" netware servers; the network connection (ping) is ok, but the problem is to see services (a kind of novell active directoy, etc..)

In 3Com and Catalyst he has had to disable IGMP snooping (see the attachment).
Is there something like this on Procurve ?

thanks in advance
kind regards
Davide
6 REPLIES 6
Highlighted
Honored Contributor

Re: HP ProCurve 5400 and Netware servers

By default IGMP is disabled on the ProCurve switches, so unless they've specifically enabled it I doubt that's the problem.

5400(config)# vlan 1
5400(vlan-1)# ip igmp

To disable

5400(vlan-1)# no ip igmp

Highlighted
New Member

Re: HP ProCurve 5400 and Netware servers

Hi,

make sure by sniffing, that DHCP type 8 ("Inform", used for service locator protocol) is delivered to dhcp server, and the answer really is delivered to the client.

Regards


haegi
Highlighted
Frequent Advisor

Re: HP ProCurve 5400 and Netware servers

What kind of problem customer had ?

I think their stations dont see NetWare tree - this is the most frequently error .This is relative to spanning tree protocol and resolved simple - the ports connected with such stations must be set to "Fast Mode" instead of "Normal" , by default in Spanning Tree Menu.

IGMP snooping dont relate to this problem ,IMHO.
Highlighted
Honored Contributor

Re: HP ProCurve 5400 and Netware servers

Andrew is on the ball there. With MSTP, prior to K.12.04? you needed to set your edge ports to edge status with:

5400(config)# spanning-tree edge-port

With the latest releases you should not need to do it, but there is a small bug at the moment which causes unnecessary topology changes so in the meantime I would recommend setting your edge-ports with the 'admin-edge-port' command.

5400(config)# spanning-tree admin-edge-port
Highlighted
Frequent Advisor
Solution

Re: HP ProCurve 5400 and Netware servers

Matt,+1 8)))

Another issue may be happened when UDP broadcast packets from Netware clients cannot reach NetWare servers if they are not reside on
same VLAN . The decision are here -

Assume Netware server is in vlan4 and had IP address 1.1.1.19 and clients are in vlan5 (no matters for us their IP addresses ).

(config)#ip broadcast-forward
(config)#vlan 5
(config-vlan-5)#ip forward-protocol udp 1.1.1.19 427
(config-vlan-5)#ip forward-protocol udp 1.1.1.19 524
(config-vlan-5)# wri me

If Yuor customer had many servers of tree and that servers are in one vlan (let it be, by example 1.1.1.0/24) you may write like this


config)#ip broadcast-forward
(config)#vlan 5
(config-vlan-5)#ip forward-protocol udp 1.1.1.255 427
(config-vlan-5)#ip forward-protocol udp 1.1.1.255 524
(config-vlan-5)# wri me

And may be some woodoo with Novell Clients on workstations, but it is not HP issue 8)))))
Highlighted
Valued Contributor

Re: HP ProCurve 5400 and Netware servers

Tahnks to all, but Andrew has solved the problem.

My customer thought that Procurve 5400 was a simple L2 switch and the udp forwarding was the last of his problems.

Now all is working fine.

regards
Davide