Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple ip's in same vlan routing

 
SOLVED
Go to solution
Highlighted
Contributor

Multiple ip's in same vlan routing

Hi,

on Comware we can do something very simple as : 

interface Vlan-interface111
ip address 10.90.111.254 255.255.255.0
#
interface Vlan-interface254
ip address 192.168.254.251 255.255.255.0
ip route-static 0.0.0.0 0.0.0.0 192.168.254.254

Which means that we use vlan 254 for routing between vlan111 and other vlans (outside of this switch).

One problem, i can only define one ip address per vlan on a 1920 anyway, higher end switches allow more then one ip address).  Now i want to implement the same thing on an Aruba 2930F which does allow multiple ip's in one vlan.

vlan 111
name "VLAN111"
untagged 46
tagged 1-45
ip address 10.35.111.254 255.255.255.0
ip address 10.90.111.254 255.255.255.0
exit
vlan 254
name "VLAN254"
untagged 48
ip address 192.168.254.251 255.255.255.0

primary-vlan 254
management-vlan 254
exit

ip default-gateway 192.168.254.254

Initially this works, i can ping 192.168.254.251 and 10.90.111.254 successfully.  However when i plug in a device in port 46 (which is is vlan 111) i can no longer ping 10.90.111.254 (i can however ping to 192.168.254.251).  And to be clear, the device does not have address 10.90.111.254.  Nothing spectacular shows up in the logs, except that vlan 111 comes online when i plug in the device...

Anyone having an idea?

2 REPLIES 2
Highlighted
Contributor
Solution

Re: Multiple ip's in same vlan routing

Did a little bit of testing this morning...  Following works : 

vlan 111
name "VLAN111"
untagged 46
ip address 10.35.111.254 255.255.255.0
ip address 10.90.111.254 255.255.255.0
exit


vlan 254
name "VLAN254"
untagged 48
ip address 192.168.254.251 255.255.255.0

Then add a gateway :

ip default-gateway 192.168.254.254

And finally, enable routing

ip routing

DO NOT SET :

primary-vlan 254
management-vlan 254

Highlighted
HPE Pro

Re: Multiple ip's in same vlan routing

Hello pnobels,

Aruba switches (previously ProVision) support multiple IP addresses on a vlan, this is an outdated technology known as "multinetting": basically, the idea was to route traffic without having a router. Since the 2930 model is a L3 switch, You do not need this functionality. Comware-based switches do not have this option.

A not very detailed HPE document:

https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-c02898663

Regards

I am an HPE Employee

Accept or Kudo