BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

C7000 OA update 2,02 -> 2,30 Can't see blades.

 
SOLVED
Go to solution
Highlighted
Advisor

C7000 OA update 2,02 -> 2,30 Can't see blades.

Hey,

I have just updated the OA on our C7000 chassis from version 2.02 to 2.30.

However when I logged back into OA on the webinterface the front view showed no blades. The SAN og ethernet switches are shown as normal.

I then tried to pull all blades from the chassis and reattach them. This caused them to reappear in OA webinterface one by one. But after some time (Around 30 minutes) the blades dissapeared again. In the meantime I have powered them on and they are running in production now so I can't pull and reattach them again.

When telnetting to the OA I can see the servers by issuing show server all.

Any help is appriciated.
16 REPLIES 16
Highlighted
Valued Contributor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

Quick fix. Remove the OA module, wait at least 10 seconds then insert it.

PS: If you have two OA modules, verify they are both at the same firmeware level.
Highlighted
Honored Contributor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

Hi,

did you first verified the version of the servers iLO firmware and updated them to the required min. version like explained in the release notes ? V1.60 is minimum version requried when running OA F/W 2.30.



In the mean time OA F/W V2.30 is replaced by V2.31 but just for a minor fix related to language settings in the browser.

See release notes here:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=329290&prodSeriesId=3188465&swItem=MTX-19378b1d89994404af9c30a820&prodNameId=3188475&swEnvOID=1005&swLang=13&taskId=135&mode=4&idx=2


HTH

Kris
Highlighted
Honored Contributor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

Highlighted
Advisor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

I have updated all blades using the firmware CD 8.20 prior to updating the OA. That includes the ILO version 2.60.

Is there any way I can check from CLI what version of ILO there is on the servers?

I really need your help on this. :(

Thanks
Highlighted
Honored Contributor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

Telnet into the OA and run this CLI command:

show server info X (X = bay number server blade)

At the end you will see information like the one below :

Management Processor Information:
Type: iLO2
Name: ILOxyzxyzxyz
Firmware Version: 1.61 Aug 31 2008
IP Address: xx.yy.xx.yy
MAC Address: 00:1B:4B:D2:69:60
Highlighted
Advisor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

I think we are narrowing down on the problem.

Prior to the update I checked the content list of the firmware cd 8.20. According to this ( ftp://ftp.compaq.com/pub/products/servers/management/smartstart/FWCDContent820.pdf ) document ILO is in version 1.60. However the above command showed that only ILO version 1.50 is installed on all blades.

I then booted one of the blades on firmware CD 8.20 again to check what version it would install and it said ILO version 1.50. (Which was already installed.)

So I think we have found the problem now. The question now is, how do I fix this?

The servers are running VMware if I for some reason need to flash ILO manually. Any help is much appreciated.

Best Regards
Highlighted
Honored Contributor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

Did you update the OA directly from 2.02 to 2.30?
Highlighted
Advisor

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

Yes I did update it directly. I couldn't find any documents telling me that I needed steps to update.

But I still believe the problem is related to the ILO firmware being in version 1.50 when the 2.30 (2.31) requires ILO version 1.60.

I see now that version 8.30 of the Firmware CD has arived. I will try this version tomorrow.

But since I'm running out of time on this I would like to know how to flash the ILO manually when I'm using Vmware on the blade servers. How do I do that if the ILO from the firmware CD 8.30 is still only version 1.50.
Highlighted
Valued Contributor
Solution

Re: C7000 OA update 2,02 -> 2,30 Can't see blades.

How to manually update iLO firmware on a ESX/VMware server using the Windows online ROM Flash component.

- goto hp, support & drivers, product=bl460c
- Operating system = Windows 2003
- select Firmware - Lights-Out Management
- select Online ROM Flash Component for Windows - HP Integrated Lights-Out 2
(current verson 1.61b)
- click download, SAVE cp009768.exe to a folder
- open folder, double click cp009768.exe
- click Extract... (not Install)

You will now have the binary firmware file ilo2_161.bin in a folder.

Web into the iLO, select administration, firmware update, simply browse to the above ilo2_161.bin

The iLO2 will reboot and come back online in about 60 seconds. This will not reboot the ProLiant server.

TC