BladeSystem - General
Showing results for 
Search instead for 
Did you mean: 

Re: Insight Agents -- Storage Agent


Insight Agents -- Storage Agent

Hello. I have VMware ESX 3.5 u1 running on a bl685c. I've installed the latest copy of the HP Insight Management Agent for the device however I don't see any information for my local disks. I do see file system storage space but nothing related to the physical disks or the array in the SMH or when I mibwalk. What could I be doing wrong?
Honored Contributor

Re: Insight Agents -- Storage Agent

Run repair / configure agents job and re-identify the server. and SNMP strings match ?
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi

Re: Insight Agents -- Storage Agent

How do I run the repair on the agent? Here is the snmpd.conf I am using.

syscontact "ContactName"
syslocation "Address"

rocommunity public SERVER.FQDN.COM
rwcommunity private SERVER.FQDN.COM
rwcommunity public localhost

trapcommunity TRAPCOM

# VMware MIB modules. To enable/disable VMware MIB items
# add/remove the following entries.
dlmod SNMPESX /usr/lib/vmware/snmp/

Re: Insight Agents -- Storage Agent

Which version of the IM Agents are you running? The support for ESX 3.5 U1 was added in IM Agents version 8.0.0 (A) which is available for download here -->

(Check the Enhancements tab).

Couple of other points which might help:

You can check if all the sub-agents are running. Type the command "service hpasm status" from the service console, and check for the output. Specifically, you would want to see if the sub-agents for storage are running.

Is ESX installed on the local disk or are you Booting from SAN?

If you are using a Qlogic or Emulex HBA, you might have to install the respective SNIA library files. The steps to install the libraries are avialable in the README file of the Insight Management Agents for VMware.


Re: Insight Agents -- Storage Agent

I did an uninstall of the agents yesterday and reinstall of the latest version specifically because of the U1 support -- still no go.

Yes, the agents seem to be running:

Status of Storage Agents (cmastor): cmaeventd cmaidad cmafcad cmaided cmascsid cmasasd
cmaeventd is running...[ OK ]
cmaidad is running...[ OK ]
cmafcad is running...[ OK ]
cmaided is running...[ OK ]
cmascsid is running...[ OK ]
cmasasd is running...[ OK ]
cmanicd (pid 4702) is running...

And yes, ESX is installed to the local disks with the VMFS volumes being located on a SAN (QLogic HBA). I'm more interested in monitoring the local disks -- would I still need the QLogic libraries?

Re: Insight Agents -- Storage Agent

Also, when I run the test in the README.txt of "snmpwalk -v 1 localhost -c public enterprises | grep hp" it returns nothing. The test of "snmpwalk -v 1 localhost -c public enterprises | grep 6876" does work though.

Re: Insight Agents -- Storage Agent


dlmod cmaX /usr/lib/

needed to be added to my snmpd.conf file.

Re: Insight Agents -- Storage Agent