BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Re-purposing an old BL460c G6 - system hangs on any reboot

 
Highlighted
Occasional Contributor

Re-purposing an old BL460c G6 - system hangs on any reboot

I managed to get my hands on and old unit with dual Xeon X5670 and 92GB Ram that was retired back in 2016 and stored in a warehouse. After checking out the price of a second-hand enclosure, I decided it wasn't worth it, so I bypassed the power connector and connected the system to a HX750 corsair PSU, which is capable of supplying 40Amps on a single 12V connector. I solved networking by using an USB 1GB Ethernet adapter. I found a source which claimed that you can get the unit online without Blade centre controller by switching on the number 5 switch on the unspecified System maintenance switch close to the CPU 1 socket and behold, it worked. The booting process went fairly smooth and I managed to install the Window Server 2016 without any major issues.

However, I noticed that the system hangs after any reboot, be it while exiting BIOS or restarting after the server update. System shutdown works fine. I’m guessing it is connected to the fact that I am missing the blade centre controller and the system is hung waiting on something?

My questions:

  1. Can anyone provide me with schematics/manual that describes the function of the unspecified system maintenance switch? I would like to know more, maybe I can solve my issue by disabling some feature.
  2. I am not entirely sure how to update BIOS/Firmware. I downloaded the latest BIOS update and followed the directions, but the system errors out after booting on the USB key. It launches the embedded program, but then claims that it is unable to execute commands/find the correct data.
    https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=3884100&swItemId=MTX_56205f78f80f402db18b132bbe&swEnvOid=4184#tab2

I know that I’m not doing things by the book, but it’s either this or the scrapyard, so I would like to salvage this unit and reuse it. The server runs fine, as long as I don’t have to reboot it, which means that a remote location is out of the question.

 

4 REPLIES 4
Highlighted
Acclaimed Contributor

Re: Re-purposing an old BL460c G6 - system hangs on any reboot

How about cooling? You have no fans.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Highlighted
Occasional Contributor

Re: Re-purposing an old BL460c G6 - system hangs on any reboot

I made a custom alu case and mounted three of these at the back, pull mode. The CPU Block Temp is under 35°C, using a temperature probe just to be sure. https://www.ebay.com/itm/Nidec-Corporation-DR04XLG-12PUS1-40x40x50mm-Server-Fan-Ventola-per-Case-12V/283187341314

As said, the system is stable, it only hangs on reboot.

Highlighted
Honored Contributor

Re: Re-purposing an old BL460c G6 - system hangs on any reboot

I haven't looked in awhile, but just saw a C3000 enclosure with power supplies for ~200.00 , a Cisco switch module for ~16.00 and an OA module for ~23 on ebay.  might be easier than trying to wing it 

No support by private messages. Please ask the forum! 
Highlighted
Occasional Contributor

Re: Re-purposing an old BL460c G6 - system hangs on any reboot

The C3000 enclosure seems to be around 700$. I can get a C7000 for 350$, but it just like a massive overkill and a waste of space. Anyway, it turned out to be an hardware issue. I had an identical blade lying around, so I swapped the components and voilà, no more issues with reboot. The back connector on the first blade had visible damage, so that might be the cause.