BladeSystem Storage Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: SB40C - how to configure?

 
Highlighted

SB40C - how to configure?

Hi - this seems like a dumb issue but it's beating me... how to create a storage volume on an SB40C.

I've got my BL460c blade (I've tried both G1 and G6), with my SB40C next to it with some disks.  The Onboard Administrator confirms that they are paired up together.

I'm expecting to see the SB40C P4xx boot during the blade post, but it doesn't.  I've booted off a recent SmartStart CD (8.7) and run the ACU, but the SB40C isn't shown.  I've gone into the blade BIOS and set/reset various likely parameters, including a full config reset, but no good.

What am I missing?  I'm sure to kick myself.

Cheers,
Andy

11 REPLIES 11
Highlighted
HPE Pro

Re: SB40C - how to configure?

Hi Andy, 

Please find the HP StorageWorks SB40c Storage Blade - Installing the Storage Blade

https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-c00948030

Installation guidelines

Follow these guidelines when installing the SB40c:

An SB40c supports one partner server blade, and a partner server blade supports one SB40c.

Install hard drives in the SB40c before installing the SB40c in the enclosure.

Be sure that the partner server blade is powered down before installing the SB40c.

Onboard Administrator is used to configure the enclosure and the SB40c. To function with the SB40c, Onboard Administrator version 1.10 or later is required.

Guidelines for installation with a half-height partner server blade
When installing the SB40c with a half-height server blade, observe the following additional guidelines:

Install the SB40c in any device bay.

If the SB40c is installed in an odd-numbered bay, install the partner server blade in the adjacent even-numbered bay to the right.

If the SB40c is installed in an even-numbered bay, install the partner server blade in the adjacent odd-numbered bay to the left.

 

Regards, 

Vijay 

I am an HPE employee
Highlighted

Re: SB40C - how to configure?

Thanks Vijay,

Yes, i saw that doc. My OA is 4.4 (Dec 2014) - so I'm supposed to run ORCA or the ACU from the OA gui? Or maybe it's only available via SSH? I'll check that out thanks.

Do you have any pics or links mid-setup?

Thanks again, Andy
Highlighted
HPE Pro

Re: SB40C - how to configure?

Hi Andy, 

Array Configuration Utility (ACU) software makes you easy to configure and expand disk drive array & i dont have screen shot. 

Regards, 

Vijay 

I am an HPE employee
Highlighted

Re: SB40C - how to configure?

Yep, I’m familiar with the ACU when run via Smartstart or an OS.... as noted above I’ve run the ACU via SmartStart (as the host OS in the blade is ESXi) but it didn’t see the array controller in the SB40C.

As the OA sees the blade and storage blade as paired I’d guess there’s a connection in place between the two, any thoughts about why the ACU doesn’t see the P4xx?
Highlighted
HPE Pro

Re: SB40C - how to configure?


Is there any embedded Adaptec SATA Raid controller enabled in the bios, if that is the case ACU does not detect the raid controller.

Is the controller detecting in the bios? If not,  please check removing and reseating the controller, cache and battery

If controller is detecting in the bios, please check what is the ACU version installed, if not latest please flash with the latest and check.

You can try clearing the Nvram and add the controller and check as well.

Is there any entry in the event logs about the controller failure or error  etc?

Please find the Array configuration utility (ACU) guide for more troubleshooting.

http://h10032.www1.hp.com/ctg/Manual/c02289065.pdf

Regards,

Vijay

I am an HPE employee
Highlighted

Re: SB40C - how to configure?

Hi again Vijay - inline answers below:

 

Is there any embedded Adaptec SATA Raid controller enabled in the bios, if that is the case ACU does not detect the raid controller.  No adaptec SATA raid controller present

Is the controller detecting in the bios? If not,  please check removing and reseating the controller, cache and battery  Only the internal RAID controller is being recognised.  I've removed, cleaned and reseated the P400 in the SB40c, no joy.  On a whim I put the SB40C back into the chassis WITHOUT the P400 and it didn't come up/wasn't recognised so obviously when it's plugged into the SB40C daughterboard it's working at least enough to POST to the chassis

If controller is detecting in the bios, please check what is the ACU version installed, if not latest please flash with the latest and check.  n/a

You can try clearing the Nvram and add the controller and check as well.  Tried that, no difference

Is there any entry in the event logs about the controller failure or error  etc?  Nothing in the logs re the SB40C at all, but of course the SB40C doesn't get its own IML log AFAIK.

It's odd.  I've got two SB40Cs and I've tried them both with BL460C G1s, G6s, with and without the PCI passthrough mezzannine card (although that's only needed for full-height blades).

I do have an empty PCI expansion blade knocking about so I was going to chuck the SB40C controller in it to see if it was recognised, but unfortunately it doesn't physically fit - there's a lug on the PCI-E interface stopping it from being inserted.

Any other thoughts?  Given that the chassis is seeing the SB40C come up ok AND is partnering it with the blade next door, and as the midplane is apparently extending the PCI-E interface it SHOULD work!  So infuriating!

bay1.pngbay2.png

Highlighted

Re: SB40C - how to configure?

Also please note as mentioned in my earlier post that I've got 2 x SBC40c's and they both exhibit this issue, so I don't think it's a part-dead storage blade issue.

Also note that I've also moved the blades and storage blades to different bays, and also swapped the left-right relationship (staying within a bay pair of course) also with no change in outcome.

Highlighted
HPE Pro

Re: SB40C - how to configure?

Hi Andy,

This case need deep drive analysis after collecting logs etc, i would suggest you too log a ticket to investigate further.

Regards,

Vijay

I am an HPE employee
Highlighted
Acclaimed Contributor

Re: SB40C - how to configure?

It is probably not a good idea to hijack each and every SB40c related thread with your problem.

As said earlier, better your own thred.

 

However, where are the server and the storage blade installed?

If the SB40c is installed in an odd-numbered bay, install the partner server blade in the adjacent
even-numbered bay to the right.
If the SB40c is installed in an even-numbered bay, install the partner server blade in the adjacent
odd-numbered bay to the left

 

Did you check if the smart array card is really installed in the SB40c?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!