BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

 
Highlighted
Advisor

BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

Trying to install a BL460c Gen8 with a new 2 x v2 E5-2670 CPU and 256GB memory into a c7000 with FlexFabric.  The OA is 4.01 and VC is 4.1.

 

We apply the Server Profile with Ethernet and FC.   When we install HP branded vSphere 5.5 on the host is does not detect the HBA part of the CNA. 

 

Any thoughts?

 

Thanks,

-MattGG

14 REPLIES 14
Highlighted
Occasional Contributor

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

Hi Matt

 

Had the same problem with Proliant BL660c gen 8, we tried almost everything we could think off, no success. Elevated the call to Level 2 engineering and they were taking very long to resolve. So we decided to apply some classical troubleshooting methods and low and behold stumbled on the solution quite by accident. For some reason even though firmware drivers etc were off the latest HP build of ESXI 5.5 Sept 2013 could not get the server WWPN to login to fabric.

 

Basically we knew that we should find hba/fcoe info in /proc/scsi- but it had only an sa entry for the internal smart array controller so we knew something was wrong on the blade side of things. I then ran the following command from an ssh session: esxcfg-fcoe -d vmnic2 and do the ame fo vmnic3. If you go back to /proc you will see that there is an entry for the FCOE hba including it's WWN etc. From here everything should just work as normal.

 

Hope this helps you solve your issue?

 

Regards

 

Kumi Chetty ( HP South Africa)

Highlighted
Occasional Visitor

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

Hi Kumi Chetty,

 

I would like to extend my gratitude to you for your information on this, I have the same issue with 18 x blade servers and HP support have been very below par to say the least!!!

 

Now I would like to know why that fixes it and why this is not already known by L2 HP support.

 

A massive thank you again to you, legend!

:)

 

Spoiler
 

 

Highlighted
Respected Contributor

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

To vent I had the same problem with 5.1.  Support was utterly useless.  I found the link to the fix on VMware's site and the rep ignored me when I said we should try it.  This was after a week and a half of back and forth.  I finally just did it and it resolved the issue.

 

I still can't believe that it isn't documented somewhere within HP.  They should have been able to provide me a fix right away for this issue.  

 

To say I was dissappointed in support is an understatement.

Highlighted
Visitor

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

Command “esxcfg-fcoe -d vmnic2 “ is a ESX console command, used to create fabric login in ESX OS. If there are any hardware or blade issue fabric login creation would fail.

 

Steps to configure FCoE,

 

  1. Change the default  Nic Personality from ISCSI to FCoE in RBSU.
  2. If there a VC setup, Create the SAN Fabrics FCoE_A and FCoE_B configure appropriate uplink ports, refer 36 Page VC cook book if need more help.

   http://h20628.www2.hp.com/km-ext/kmcsdirect/emr_na-c02616817-5.pdf

 

3. In order to configure FCoE on VMware ESX5.X either use Esx console or VI Client  GUI, for more help refer below link shared for Intel Chip adapters.

 

http://www.intel.in/content/dam/www/public/us/en/documents/guides/ethernet-x520-configuring-fcoe-vmware-esxi-5-guide.pdf

 

thanks

Javeed

Highlighted
Honored Contributor

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

Hi Kumi Chetty,

 

you saved my Day!

 

esxcfg-fcoe -d vmnic0

 

Was the solution for us too.

 

We have BL560c Gen8 with v2 CPU and 534FLB & ESX 5.5.

 

Thank you.


======================
That was not planned in this way.
Highlighted
New Member

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

I've been struggling with the same issue for almost a week now. BL460c Gen8 (745915-S01) with a 534FLB and a 554M. The 554M showed up, no problem. Finally ran across this article from VMware: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2034702. Now I can see my 534FLB...
Highlighted
Occasional Collector

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

I have Same Problem, Please run below command and activate HBA on ESXi host,

 

1-       Login to ESXi CLI.

2-       Determine which interfaces are FCoE capable
      
# esxcli fcoe nic list.

3- Activate FCoE:
# esxcli fcoe nic discover –n vmnicX (vmnicX is VMNIC Number)

4- Verify the interface is activated by one of the steps below:

      # esxcli fcoe adapter list

      # esxcfg-scsidevs –a

Note:
If it is not activate, please reinstall the driver.


Command Scritp

esxcli fcoe nic list
esxcli fcoe nic discover -n vmnic4  (vmnicX is VMNIC Number)
esxcli fcoe nic discover -n vmnic5  (vmnicX is VMNIC Number)
esxcli fcoe adapter list
esxcfg-scsidevs -a

 

Thanks

Shriniwas

Highlighted
Occasional Advisor

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

I got to say: thank you for sharing, it worked for me too !!
Highlighted
Visitor

Re: BL460c Gen with V2 Intel CPUs can't see 534FLB's HBA?

 

Got the FCoE ports working but now it seems the enet ports are also still visible.. Anyone got a solution to fix this as I am stumped here.. Probably missing some dumb something but stil..

 

I work for HP

A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

Hit that Thumbs Up button if you find this helpful.