Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

SSP: Not all WWNs listed

 
Highlighted
Regular Advisor

SSP: Not all WWNs listed

Hi everyone,

We have:
1x HP EVA4400
1x MSA 1500cs
2x HP Brocade 4/12 FC switches
16 HP Blade c-class with two fiberchannel cards

The problem is as follows:
On the MSA1500cs controller i have enabled SSP (Selective Storage Presentation) and configured all the Blade WWNs to some LUNs. The problem is: i only see the primairy WWNs listed that are connected to Fiber Switch 1. All other WWNs (the second FC card of every blade) are not listed!

This means: Once my primairy FC Brocade switch fails all Blade servers will try to connect to the MSA1500cs using the their 2nd FC card, which is connected on the 2nd FC switch. Since my MSA1500cs has only the primairy WWNs configured in SSP the entire storage will fail for all Blades!

Why are all the 2nd FC card WWNs not listed in SSP? The EVA4400 lists them all! When i use the Qlogic SAN Surfer i can see all the FC cards which are in the blades, primary and secondary. Zoning is not configured on the FC switches.

Anyone?

Many thanks!
Joris Kemperman
10 REPLIES 10
Highlighted
Honored Contributor

Re: SSP: Not all WWNs listed

Maybe the second MSA controller did not receive a SAN notification to add the connection object, but that is a bit unlikely if all 16 blades did not register.

Does the second MSA controller have proper SAN connectivity? Have you tried to reboot a blade to see if it shows after the operating system is up again - the connection usually is created when an inquiry is sent from the OS.
.
Highlighted
Regular Advisor

Re: SSP: Not all WWNs listed

Blades have been rebooted.

The strange thing is that the EVA4400 finds both WWNs of every Blade and the MSA1500cs doesn't.

You think this could be a MSA controller error?
Highlighted
Honored Contributor

Re: SSP: Not all WWNs listed

Yes, looks like the problem is with the MSA / its connectivity. Have you checked whether controller_2 is logged in to the Fibre Channel switch?
.
Highlighted
Regular Advisor

Re: SSP: Not all WWNs listed

Hi Uwe,

First of all thanks for your help. Currently i cannot head over to the MSA1500cs since it's located in a datacenter but your answers defenately makes sense, i think my 2nd controller is having troubles.

Can i just pull out the 2nd controller and replug it in without disturbing the connectivity to all the LUNs allocated on the MSA1500cs?
Highlighted
Honored Contributor

Re: SSP: Not all WWNs listed

Hi,
yes in dual config the controllers are hot-replacable:

a) the hot replace should be commited only in the low I/O times. If you do it in the heavy I/O times, it may cause the pause, performance decrease...
b) it should be first disabled via the SMU/MSA-CLI prior to the hot-removal


the pain is one part of the reality
Highlighted
Regular Advisor

Re: SSP: Not all WWNs listed

Hi!

Thanks for your reply! How do i disable the controller exactly? I'm only used to work with the Array Configuration Utility.
Highlighted
Honored Contributor

Re: SSP: Not all WWNs listed

Highlighted
Regular Advisor

Re: SSP: Not all WWNs listed

Thanks Ibaltay,

Page 55 gives an important notice: the controller cannot be re-enabled after beeing disabled. Any idea what they mean with that?
Highlighted
Trusted Contributor

Re: SSP: Not all WWNs listed

Unlike the HSG's which allowed restarting the controllers, the Disable Controller option only Quisces the output and prepares the controller for removal.

So After the option is Selected you have to manually reseat the controller for it to re-boot.