General
cancel
Showing results for 
Search instead for 
Did you mean: 

CDE Does not come up after change in netconf

 
SOLVED
Go to solution
Highlighted
Advisor

CDE Does not come up after change in netconf

Hello,

We are testing something on the netconf. We changed the Gateway entry to something incorrect purposely and as soon as we reboot the computer, CDE does not come up. It has a gray screen with X on it. It's stuck there.

How do I interrupt the boot up process, go to a console so it doesn't go to CDE and undo the change we did? I'm sure it has something to do with putting an incorrect gateway entry in netconf.

Or any other advice to fix it? Your help is greatly appreciated. Thanks!

Please HELP! Thanks so much as always!
Emily
8 REPLIES 8
Highlighted
Outstanding Contributor
Solution

Re: CDE Does not come up after change in netconf

Emily,

During boot-up, you will see a message stating you have 10 seconds to interrupt. At that point, hit a key to interrupt the boot process and enter "hp-us -is". This will boot you in single user mode and log you in as root. From there, you can fix your netconf file. As you've seen, CDE doesn't like it when it can't complete host name resolution!


Pete

Pete
Highlighted
Valued Contributor

Re: CDE Does not come up after change in netconf

Pete,

I think you have a typo here. I believe it should be "hpux -is" at the prompt.

Also the first prompt you should see is the BCH (boot console handeler)prompt. So here are the steps

1. Hit any key when the message comes up to interupt with in 10 seconds.
2. From the BCH prompt type - boot pri (this will tell the system to boot from it's primary path)
3. Answer yes when asked if you want to interact with "ISL".
4. From the ISL prompt type "hpux -is"

This should put you in single user mode.
Highlighted
Honored Contributor

Re: CDE Does not come up after change in netconf

Hi Emily,

If the system is on the network and if only the gateway entry is wrong, then you can still connect to it from another system from the same subnet. Try telnetting into it.

If there is no network connectivity, then follow the process outlined by Pete.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Highlighted
Advisor

Re: CDE Does not come up after change in netconf

Thank you all! but I need more help.. please...

Here's my screen:

INIT: Overrriding default level with level s
INIT: Single User Mode
#

*I was expecting that I could do "vi" here of my /etc/rc.config.d/netconf to undo my changes but I can't. It says,
#sh: vi not found.

What do I do next?
Highlighted
Honored Contributor

Re: CDE Does not come up after change in netconf

/usr is not mounted. vi lives in /usr/bin. mount it manually (and /var as well) to enable vi
Highlighted
Honored Contributor

Re: CDE Does not come up after change in netconf

Emily,

Couple of things you need to do to setup working environment in the single user mode. Mount /var, /usr and /tmp

#mount /var
#mount /tmp
#mount /usr
#export TERM=hp
#clear

Clear should work. If it doesn't then try TERM=vt100 and vt220. One of them should work. Once clear is working, then you will be able to edit /etc/rc.config.d/netconf file.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Highlighted
Advisor

Re: CDE Does not come up after change in netconf

PERFECT! YOU ALL SAVED MY LIFE! Thanks so much! It's back working now.
Highlighted

Re: CDE Does not come up after change in netconf

I was experiencing the same problem. Thank you guys!