General
cancel
Showing results for 
Search instead for 
Did you mean: 

couldn't find per display information

 
SOLVED
Go to solution
Highlighted
Super Advisor

couldn't find per display information

Hello gurus,

I have a linux (Fedora core 1, XFREE86 ver. 4.0 )box on which I want to export the display from an HPUX11.00 server. On the UX machine I give the right command
setenv DISPLAY :0.0
and I can see with echo $DISPLAY that the new value is right. On the linux box I give
xhost + to enable the remote access end echo $DISPLAY on the linux box returns
:0.0
..but whatever X application I start on the UX server it returns "couldn't find per display information".
Another colleague with a gentoo box on the same LAN segment doesn't have any problem with that ...
Where should I dig further?
N.B. - the linux box is actualy a dual boot machine, the second OS is Window$2000 and I can start from Window$ using ReflectionX an XDMCP session to the UX server without problems...

thank you all,
ionut
If it weren't for STRESS I'd have no energy at all
5 REPLIES 5
Highlighted
Honored Contributor

Re: couldn't find per display information

Hello Ionut,

please try the following and report back on the
results:

1.) Open a graphical session on your Linux box.
Do the xhost + in there, run xhost without
arguments to verify access control
2.) Telnet from the to the HPUX server
3.) ping back from the there to your Linux box using the same name/ip address as you want to use in the setenv DISPLAY
4.) set your DISPLAY on the HPUX server
5.) Run a >>simple<< application (like xclock). Report back on the messages you receive.

Greetings, Martin
Highlighted
Super Advisor

Re: couldn't find per display information

Hi,

xhost shows me access control disabled, clients can connect from any host,
from the Unix server I can ping the linux box, but trying to start a xterm failes with the same damn message :-(
/usr/X11R6/bin is in the path, the X server is running and displaying on :0.0, I don't have any other idea ...
What is worse, I have the IP 10.1.40.77, from another linux box (with RedHat7.3 ) with IP 10.1.40.89 I can start an X application on the Unix server ..
If it weren't for STRESS I'd have no energy at all
Highlighted
Super Advisor

Re: couldn't find per display information

Hi,

who knows how can I start the X server without -nolisten tcp option ? It looks like this is the problem - x11 doesn't listen on tcp , but the problem is I couldn't find the right configuration file - I have commented out such a line in the conf file for the font server but it's not enough.
If it weren't for STRESS I'd have no energy at all
Highlighted
Honored Contributor
Solution

Re: couldn't find per display information

Cool... working in 2 forums with the same question ;-)

You might check the /etc/inittab file.
Or it is in the xdm configuration files. On most linux versions X is started by xdm.

You might look in your process list for the parent of the X server process to view which program is responsible...
Every problem has at least one solution. Only some solutions are harder to find.
Highlighted
Super Advisor

Re: couldn't find per display information

first your well deserved 10 points, Elmar - you gave me the right idea - now: the problem was the variable DisallowTCP=true who is defined in /etc/X11/gdm/gdm.conf file, the gdm deamon starts X with -nolisten tcp option if this variable is true, so I have set it to false and restart X, know is working perfectly.
If it weren't for STRESS I'd have no energy at all