Showing results for 
Search instead for 
Did you mean: 

Deskjet 9800 using CUPS and IPP

New Member

Deskjet 9800 using CUPS and IPP

We have connected a Deskjet 9800 to a Fedora Core 3 Linux via USB. Printing from this box works fine, but when sharing to windows clients (XP PE, 2000) via IPP (http://...), we can indeed find the printer. But when it comes to finalizing the printer installation, the spoolsv.exe process gets full cpu load and won´t finalize the installation. The printer is displayed and remains in status 'opening'.

Previously we had a deskjet 970xi connected using the same settings. That worked pretty fine.

So is there maybe some other ports, protocols, etc. needed by the new printer/driver? We should know this since the linux box is in a DMZ where the ports are forwarded to via a linux router.
But I don´t think it´s the routing since it neither worked on a windows 2003 server which is located in the same DMZ.

Thanks for your help!
Honored Contributor

Re: Deskjet 9800 using CUPS and IPP

Hi Moritz,

Welcome to the forums!

I've moved this one to the Linux Category,
The experts here will have some suggestions for you.

Hope this helps,

New Member

Re: Deskjet 9800 using CUPS and IPP


it seems I solved the problem. I removed all other not-in-use IPP-Ports on windows. Then it worked.
But somehow it still won´t work on an ibm t43 win xp pro even though it works on other xp pros. There are no personal firewalls, missing security updates. Another printer on the same cups works just fine. And I do not get any log output from cups. The t43 simple says that it was unable to print.

So it seems that this is not linux issue. Looks more like a windows problem. Thanks anyway.

New Member

Re: Deskjet 9800 using CUPS and IPP

Hello Forum,

we solved that issue by using the HPLIP backend drivers under linux. Somehow it wouldn't work with the raw driver.

Now we wanted to install the network printer on all windows clients (xp home, xp pro, 2000) on our LAN.

Installing the printer via ipp (http://server:631/printers/Printername)
works fine on _all_ clients. But on some clients (XP Pro, XP Home, doesn't
matter) printing just won´t work ("Document could not be printed").
I have attached the debug2 cups log for both a working xp pro test
page print and a none working one.
The line "d [14/Sep/2005:19:42:20 +0200] ReadClient: httpGets returned
EOF..." seems to be telling us the error. But I just can't deduce anything
from that. The working test page print has "D [14/Sep/2005:19:30:34 +0200]
ReadClient: 10 POST /printers/NFColorA3 HTTP/1.1" instead of the error
message above.

I really hope that you can help us. We just can't tell why it would worl on some clients and no on the others. It doesn't make any sense to me.

Please advice! Thanks in advance.

Moritz Boehme