Showing results for 
Search instead for 
Did you mean: 

Grub/LILO install fails on Debian amd64 port


Grub/LILO install fails on Debian amd64 port

HP Proliant DL385 with HP Smart Array 6i controller.
Two Dual-core Opterons with 6 GB of RAM.
Trying to install the netinstall of the amd64 port.
However, both grub and LILO fail to install citing errors with finding the device.

I receive the following if I try to proceed, skipping the boot loader install.

"You will need to boot normally with the /boot/vmlinuz kernal on partition /dev/cciss/c0d0p1 and root = /dev/cciss/c0d0p1 passed as a kernal argument"

I have tried to install a /boot partition as well as a sing root partition.

Any suggestions?

Re: Grub/LILO install fails on Debian amd64 port

Hi Ryan

I'm going to make this tests this afternoon:

First: I'm going to use Reiser fs instead

Second: I'm going to make a grub floppy,
--no matter what file system-- and transfer the floppy image to hard disk.

I found them:

They say something about driver but I don't think so. I think it is a parsing problem in grub-install script.

I386 versions could be installed flawlessly, I tested two I386 versions yesterday.

Hope it helps
Honored Contributor

Re: Grub/LILO install fails on Debian amd64 port

Hi Ryan,

I could be completely off the mark here, but do you have any other storage controllers installed, Fibre Channel etc ?

I've never used Debian but have had problems with the installer on RedHat, as it tries to stick GRUB on the the first disk device it finds - a disk on the SAN - rather than on the SmartArray disks. You have to select an advanced option to tell it to use /dev/cciss/... rather than /dev/sd...

You only notice the problem after you complete the install and then the thing won't boot ...


Trusted Contributor

Re: Grub/LILO install fails on Debian amd64 port

Grub fails on amd64 port, in native mode. The recent testing "etch" images have got this issue fixed. In the meantime, you can get a Knoppix LiveCD and install grub on to the MBR of your drive from that. It worked on an installation here.
Debian GNU/Linux for the Enterprise! Ask HP ...