cancel
Showing results for 
Search instead for 
Did you mean: 

LC_ALL setting on HP-UX 11.23

 
Highlighted
New Member

LC_ALL setting on HP-UX 11.23

Our database needs Unicode (UTF8) characterset.

We put following LANG and LOCALE environment settings into /etc/profile

LANG=en_US.UTF-8
LC_ALL=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
export LANG LC_ALL LC_COLLATE LC_CTYPE LC_MESSAGES LC_MONETARY LC_NUMERIC LC_TIME

we get following warning when we type Unix commands, such as vi....

------------------------------------------
Warning! One or more of your selected locales are not available.
Please invoke the commands "locale" and "locale -a" to verify your
selections and the available locales.

Continuing processing using the "C" locale.
---------------------------------------------

When we replaced en_US.UTF-8 with C.utf8, that warning disappered.

Do en_US.UTF-8 and C.utf8 mean the same thing on HP-UX?

Thanks in advance.
2 REPLIES 2
Highlighted
Valued Contributor

Re: LC_ALL setting on HP-UX 11.23

Seems to be a problem with missing locales.

run command:
locale -a

and see whether en_US.UTF-8 is in the list?
If not, you have to install it.
abandon all hope, ye who enter here..
Highlighted
Acclaimed Contributor

Re: LC_ALL setting on HP-UX 11.23

>We put following LANG and LOCALE environment settings into /etc/profile
LANG=en_US.UTF-8
LC_ALL=en_US.UTF-8
LC_COLLATE=en_US.UTF-8

This is overkill. You either need LANG, LC_ALL or a subset of the LC_* variables.

>Srikrishan: and see whether en_US.UTF-8 is in the list?

Right. I see: en_US.utf8