Showing results for 
Search instead for 
Did you mean: 

memory for JFS inode cache isn't reallocated

Occasional Advisor

memory for JFS inode cache isn't reallocated

I have noticed that the system memory used for the JFS inode cache is retained by the OS even when all inodes on the freelist are freed.
I've done tests on HP-UX 11iv2 and 11vi3 with JFS 4.1 and no significant applications running on the systems.

For example, when I run "find /", the inode cache is filled to the max and the system memory allocated grows from about 800mb to 1.2gb (measure taken with glance -m). After about 30 mins I checked with "vxfsstat /" and I noticed the cache begins to shrink and after some hours it is almost empty, but system memory is still 1.2gb.
I've tried to put the system under memory pressure using memalloc but it began to swap without releasing the memory that was in use by the inode cache.

Is this a normal behaviour? is there some explanation?

Some of my systems have only 2gb of RAM, and I know that "find /" must be avoided, but my fear is that, in the long term and with a lot of work on the file system, this may cause a memory issue.
I also know that modifying the vx_inode and vxfs_ifree_timelag tunables I can put a limit on the cache and make it release faster....but still I can't see the system actually release that memory and reallocate it.

Please, it is very important to me to clarify that.