Showing results for 
Search instead for 
Did you mean: 

NFS locking problem?

Go to solution

NFS locking problem?

Hi folks,

Two days ago I installed the June Quality Pack Bundle on 2 of our HP-UX 11.23 servers. About 100 patches were updated including an NFS components cumulative patch for core, client & server (PHNE_38252).

One of these servers (let's call it AR1) mounts 2 directories via NFS on the other (let's call it RS1). The application on AR1 depends on these mounts as it processes messaging files when they appear in the mounted directories.
These mounts have worked without fail until the update two days ago, since then I'm seeing intermittent problems where the software running on AR1 can read but not remove a file in one of the shares.

The problem shows up in the syslog as below;
vmunix: NFS remove failed for server hprs1: RPC: Remote system error

We've been able to workaround the issue by going in to AR1 and removing the file by hand with rm, which works OK.
However we did experience the problem once when using rm very soon after the software had the problem.
This looks to me like it could be a locking issue however it's puzzling as it has only started to occur after installing the patches.
So far I've tried umounting the NFS mounts, restarting the NFS and RPC daemons on RS1 with a;
"/sbin/init.d/nfs.server stop; /sbin/init.d/nfs.server start"

But the problem persists although intermittently.
Anyone come across this issue before?
Any suggestions?

Re: NFS locking problem?

Hi Vince,

Are you sure the application is even doing file locking? Are there any entries in /var/statmon/sm on these systems? If you send a SIGUSR2 signal to the rpc.lockd daemon and examine the /var/adm/rpc.lockd.log file do you see any locks in the queues?



Re: NFS locking problem?

Thanks for the reply Dave,

Rather than sending the process a SIGUSR2 I restarted rpc.lockd on RS1 with the -l option and specified my own logfile. The problem hasn't occurred today, I think restarting rpc.lockd has sorted the issue.

Odd as the nfs.server & rpc.lockd processes were initially started on each server during bootup, and the problem didn't go away after I restarted nfs.server on RS1 (the nfs.server init script stated that the rpc processes where also restarted however I can't guarantee now that it was).

Anyway thanks for pointing me towards rpc.lockd.
I'll leave the thread open for now in case the problem happens again in the next couple of days.

Re: NFS locking problem?