cancel
Showing results for 
Search instead for 
Did you mean: 

NLS - Lang setting and more

 
SOLVED
Go to solution
Highlighted
Regular Advisor

NLS - Lang setting and more

What character set is more using?
We're seeing some problems with french characters being converter. The OS is setup with the default C. Doing a locale shows all LC_* as "C" except LANG is null. Regardless of whether LANG is set to C or null, doing a more on the file shows strange characters. Using nedit or doing vi on the file, the characters display correctly.

So what gives?
4 REPLIES 4
Highlighted
Acclaimed Contributor
Solution

Re: NLS - Lang setting and more

>Doing a locale shows all LC_* as "C" except LANG is null.

This is the American Nerd locale.

>Regardless of whether LANG is set to C or null, doing a more on the file shows strange characters.

more(1) under the American Nerd locale doesn't print non-ASCII chars and goes out of its way to tell you. See the -v option to change this. If the locale is set, you don't need -v for valid chars.

>Using nedit or doing vi on the file, the characters display correctly.

These probably just send the byte out without regard to what the char is.
Highlighted
Regular Advisor

Re: NLS - Lang setting and more

The problem we are seeing is via a telnet session to the box. In an xwindows sessions (Hummingbird Exceed) french characters are seen ok. In a telnet session, logged in as the same account, french character are converted. Doing an echo on $LANG or locale, the system comes back as C.

Wht is telnet not behaving like the rest? We are running a web app (Remedy mid-tier) that users use to input data into the back end Oracle db running on a Windows box. Oracle is setup ok and we can input and retrieve french txt fine. We suspect that the midtier app is behaving like a telnet session and not picking up the proper lang setting.

Any help appreciated.
Highlighted
Acclaimed Contributor

Re: NLS - Lang setting and more

>In a telnet session, logged in as the same account, French character are converted. Doing an echo on $LANG or locale, the system comes back as C.

Converted when using more(1) or something else?

You need to make sure both sides have the LANG set to French.

It could also be something where the stty settings need to be looked at. Stripping of parity bits?
Highlighted
Regular Advisor

Re: NLS - Lang setting and more

Issue resoved