cancel
Showing results for 
Search instead for 
Did you mean: 

not able to telnet

 
SOLVED
Go to solution
Highlighted
Advisor

not able to telnet

Hi, I'm new to Linux and just installed RH 7.1 server. without any firewall configuration. I'm not able to do a telnet to the server. It says---telnet: Unable to connect to remote host: Connection refused.
Any ideas..what may be going wrong? I tried to load with firewall config also but the result is same. Am I supposed to modify some files to make it work.
TIA
Vikas
6 REPLIES 6
Highlighted
Occasional Advisor

Re: not able to telnet

there will be a configuration file in /etc. It can be by the name defaults(but i am not sure) that file will have some entries regarding telnet. Then check the inetd.conf file also. IF possible try restarting the inetd daemon.
like to find out new things and compare with other flavours of unix
Highlighted
Honored Contributor

Re: not able to telnet

mv /etc/securetty /etc/securetty.prev
Highlighted
Occasional Advisor
Solution

Re: not able to telnet

I think it's a good idea to edit the file /etc/xinetd.d/telnet and switch disable = yes to disable = no

Then restart the xinetd
Highlighted
Regular Advisor

Re: not able to telnet

RH 7.1 by default has Telnet disabled.
Here's what you have to do.
from a prompt type the following:
chkconfig --level 35 telnet on

Then the /etc/xinetd.d/telnet file will be created for you.

You can then type:
service xinetd restart

Now your telnet will work.

FYI, you can see what services are being started when you boot by using the following:
chkconfig --list

Hope this helps!

John
Highlighted
Trusted Contributor

Re: not able to telnet

1st check if you installed the telnet rpms. If you installed it as workstation the telnet server would not be installed by default.

[root@builder /root]# rpm -qa | grep telnet
telnet-0.17-7
telnet-server-0.17-7
[root@builder /root]#

Install the telnet rpm from your installation disk if these are not installed.

- fnhalili
derekh
Highlighted
Advisor

Re: not able to telnet

Thankx a lot for y'r help.

Vikas