Showing results for 
Search instead for 
Did you mean: 

Re: Problem in starting XVFB

New Member

Problem in starting XVFB

Hi All,

I am having two machines one with headless Linux Server (Red Hat 9.0) and another with Windows 2000 client.
I would like to execute a graphic based java program which resides in headless linux machine.
I used "putty's - ssh" to access the linux machine from windows 2000.

Putty Link :

I tried with these,

- removed the monitor, keyboard and mouse from the Linux Server.

- changed the runlevel from 5 to 3 ie.made the XServer stopped using "telinit 3" command.

- tried to start XVFB which comes with the Red Hat 9.0 with the following command

" Xvfb :0 -screen 0 1024x768x16 & "

Got these errors
Error : Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!

I assume that it could not init the fonts alone but, XVFB is running. So, i tried to
execute a Graphic based Java program. But, i got the following errors

Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ''
as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.(
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(
at java.awt.image.BufferedImage.createGraphics(
at JavaHeadless.main(

Can anyone help me to start XVFB ?

any help is appreciated.

Thank in Advance
Respected Contributor

Re: Problem in starting XVFB


Have you entered and xhost + to the server you are trying to get onto/from. That may be why the java is failing, and could also point to your Xvfb problems.



New Member

Re: Problem in starting XVFB

Thanks Palmer,

Yes, i tried this command from the windows machine thru putty
xhost +

but i got the following error
xhost: unable to open
display ""

the above specified ip is my client's.
any DISPLAY setting is needed ?

Thanks in Advance
Respected Contributor

Re: Problem in starting XVFB


as far as I am aware, I believe that messages with regards to DISPLAY issues, (if the $DISPLAY env variable is set) are normally down to things like xhost, I dont really know more than that I am afraid. Are you using X11 over ssh??