General
cancel
Showing results for 
Search instead for 
Did you mean: 

problem t1lib with HPUXWSATW218 package

 
Highlighted
New Member

problem t1lib with HPUXWSATW218 package

Hello,
We need to use gd library with t1lib.

Installed depots:
- web package 2.18 (11.23-64)
- mySQL 5.0.45
- perl 5.8.8

Apache, mySQL, perl is worked OK.
Our server is (uname -a command):
HP-UX kate B.11.23 U ia64 0834457779 unlimited-user license

On the page for web package 2.18
http://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW218
exists info about gd.sl library and t1lib (only version 1.3.1).
In the table for our platform 11iv2 (64bit IPF)
points to external sources on the site
http://site.n.ml.org/download/20030303100000/t1lib/t1lib-1.3.1.tar.gz


This sources do not configure on our IA64 platform, see the error:

root@kate /depot/zrk/t1lib-1.3.1>./configure
loading cache ./config.cache
checking whether make sets ${MAKE}... (cached) yes
checking for gcc... (cached) gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for X... (cached) no
checking for Athena... (cached) libraries /usr/lib/X11R4, headers in default path
checking host system type... configure: error: can not guess host type; you must specify one
root@kate /depot/zrk/t1lib-1.3.1>

root@kate /depot/zrk/t1lib-1.3.1/ac-tools>more config.guess
....
# Note: order is significant - the case branches are not exclusive.
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
*:NetBSD:*:*)
# Netbsd (nbsd) targets should (where applicable) match one or
# more of the tupples: *-*-netbsdelf*, *-*-netbsdaout*,
# *-*-netbsdecoff* and *-*-netbsd*. For targets that recently
# switched to ELF, *-*-netbsd* would select the old
# object file format. This provides both forward
# compatibility and a consistent mechanism for selecting the
# object file format.
# Determine the machine/vendor (is the vendor relevant).
case "${UNAME_MACHINE}" in
amiga) machine=m68k-cbm ;;
arm32) machine=arm-unknown ;;
atari*) machine=m68k-atari ;;
sun3*) machine=m68k-sun ;;
mac68k) machine=m68k-apple ;;
macppc) machine=powerpc-apple ;;
hp3[0-9][05]) machine=m68k-hp ;;
ibmrt|romp-ibm) machine=romp-ibm ;;
*) machine=${UNAME_MACHINE}-unknown ;;
esac
...

You may see in the file config.guess - sources 1.3.1 not for IA64 platform !

I have installed from depot package t1lib 5.1.0 on this configuration.
Results (text from php.log):
24-Jan-2008 17:13:23] PHP Warning: PHP Startup: Unable to load dynamic library '/opt/hpws/apache/php/lib/php/extensions/g
d.sl' - Unable to find library 'libt1.sl'. in Unknown on line 0


I have checked the document HP KB docID MJFKBRC00015829 with the same results too.
I did not find the t1lib 1.3.1 for IA64 platform (depot not exists, sources not compile)


Questions:

1. on HP web site with product HPUXWSATW218 is mistake? Where is correct sources t1lib for HPUXWSATW218?
2. There is the depot t1lib that worked with package HPUXWSATW218?

best regards,
Ravil Zubairov.
4 REPLIES 4
Highlighted
Exalted Contributor

Re: problem t1lib with HPUXWSATW218 package

Shalom,

You have probably run into a bug.

I'd report it to the team at software.hp.com

1. There may not be a correct source for your platform.
2. I can't find anything in depot format.

http://hpux.cs.utah.edu/
Might find something here.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Highlighted
New Member

Re: problem t1lib with HPUXWSATW218 package

Hello,

In the site http://hpux.cs.utah.edu is nothing.

How long to wait an answer from team at software.hp.com?


best regards,
Ravil Zubairov.
Highlighted
New Member

Re: problem t1lib with HPUXWSATW218 package

Hello!
I find the problem. The HPUXWSATW218 for HPIA64 was made with different libraries for 64 and for 32 bits. gd.sl in this packet require 64 bit version of t1lib. I downloaded the 32 bit version of HPUXWSATW218 for Itanium proc. and installed. gd.sl works correctly. But another problem appears. PHP extension module oci8.sl requires 32 bit version of oracle client 9.2.0. But I can't find it anywhere. On oracle.com only exist client 9.2.0 64 bit version. All problems will resolved, if to know, how to make 64 bit version from sources. By default the libraries are made as 32 bit. Who knows, what keys are necessary for doing 64 bit library?
Highlighted
New Member

Re: problem t1lib with HPUXWSATW218 package

I find the exit.
Steps for solving oci8.sl problem for 32 bit version of HPUXWSATW218:
1. Install standart version of Oracle client 9.2.0.
2. Make links
/usr/lib/hpux32/libclntsh.so.9.0 -> /oracle/client/92x_64/lib32/libclntsh.so.9.0
/usr/lib/hpux32/libwtc9.so -> /oracle/client/92x_64/lib32/libwtc9.so

3. Edit the /bin/envvars
put strokes like this:
export ORA_NLS33=/oracle/client/92x_64/ocommon/nls/admin/data
export ORACLE_HOME=/oracle/MON/920_64
SHLIB_PATH="/oracle/client/92x_64/lib32:$SHLIB_PATH"
export SHLIB_PATH
export TNS_ADMIN=/oracle/client/92x_64/network/admin
LD_LIBRARY_PATH="/oracle/MON/920_64:$LD_LIBRARY_PATH"
export LD_LIBRARY_PATH
4. Restart Apache.

It's all steps.