Showing results for 
Search instead for 
Did you mean: 

SuSE 8.1 on Compaq EVO N1020v

Occasional Contributor

SuSE 8.1 on Compaq EVO N1020v


I have a problem trying to install SuSe 8.1 or run SuSe 7.3

When I try to installation of SuSE Linux 8.1,
no error message is displayed, but installation hangs up at "hda" scanning.
I thought that it takes some time, but after an hour, there was no progress. I choose installation under graphical environment at 1024x768 resolutions.

Although SuSe 7.3 Installation without problem, but after reboot it hangs after ???hda??? scanning.

I have laptop Compaq EVO N1020v : Intel Celeron 1.6GHz with 256 MB RAM (16 MB dedicated to video) and an 30 GB hard disk. Installing from internal DVD/CD-RW (TEAC) drive.
I have tried to install on fully clean computer as only OS, and tried to install as secondary to Windows XP HE, but still the same.

I have tried to install both (7.3 and 8.1) on other computer ??? everything gone well, so I think, that Installation disks are good.

Where I gone wrong and What Should I do ?

P.S.: All other Distributions Mandrake 9, 9.1 and Redhat 9 don't seems to have problem with my laptop. Mandrake 9.1 with Radeon accel "ON" - goes well, but still I want to have SuSE on my Computer.
Exalted Contributor

Re: SuSE 8.1 on Compaq EVO N1020v

You have already answered your question.

The later releases of Suse support the hardware. The current release does not.

If there is some reason to be on the old release, look into upgrading just the kernel and you should get your hardware support.

If the box won't boot, how do you upgrade the kernel?

In your shoes, I'd go with a later release or a different distribution.

Steven E Protter
Owner of ISN Corporation
Occasional Contributor

Re: SuSE 8.1 on Compaq EVO N1020v

Well problem is, that I like SuSE. I used to work with it on my old computer, but now I bought a Notebook (Compaq EVO N1020v w/ Cel.1.6GHz). I???ve tried another releases of Linux, I mean distributions, and all they work great.

Finally I made it !!! I put SuSE 8.0 to my computer. The same problem appears with computers with some kind of HardDrive and RedHat 8.0. In Forums they suggested to install in expert mode. SuSE doesn???t have such thing so I just Boot???ed it in ???Safe mode???, that???s mean : ide=nodma apm=off acpi=off. I think I would be enough ???ide=nodma???, but I???ll check it in few days, because now I have some job to do.

But PROBLEMS still remains:
Video : SuSe developers are really stupid at this point. Video adapter(controller/Vendor/Model) you can choose only by running XFree86 configuration with sax2. But On First boot You choose only monitor (Display). I???m still working on trying to get 1024x768 instead of 800x600. And if someone knows what should I pick for my ???ATI IGP340???, ???couse list of models really makes me confused : R200v, R200v, Radeon QQ, VE, BZ..and so on in such style.

Sound : every time when trying to configure ??? crash or freeze. I???m not getting even to the list of sound card vendors.

Battery : no indication, but it???s because of ???acpi=off??? and ???apm=off???. It???s not a problem.

Conclusion : Some of You may think, that I just stupid not getting on another distribution, or just have enough free time and have nothing to do. Well it???s all simple: I???ve tried other distributions and no problem with them, but Hey??? no problem ??? no progress. About the time : I have real job, working mostly on windows (It sucks, but at this time it???s necessarily for my job.) and wasting my free time on linux ??? just a pleasure for me.

If You have any comments about Sound or Video ??? It would be really helpful.

P.S.: Mandrake 9.1 supports my computer even with 3D hardware acceleration. :)
Trusted Contributor

Re: SuSE 8.1 on Compaq EVO N1020v

For video, check out my HP ze4100 site:

The ze4100 has a Radeon IGP 340M graphics system identical to the one on your Evo N1020v. Although I'm running Red Hat 8.0, the XF86Config files I use should work just fine on your Suse 8.0 system.