General
cancel
Showing results for 
Search instead for 
Did you mean: 

Telnet not working on HP-Ux 11.00 PA-Risc

 
Highlighted
Advisor

Telnet not working on HP-Ux 11.00 PA-Risc

I am not able to login HP-Ux 11.00 PA-Risc box by using telnet


Logs shows following error messages
# tail -f syslog.log
Mar 4 19:48:02 build-hppa-1100 telnetd[7940]: I_LINK_DEV ioctl failed: Invalid argument
Mar 4 19:48:50 build-hppa-1100 vmunix: USB HID: Device 2 has been reset
Mar 4 19:48:56 build-hppa-1100 above message repeats 200 times
Mar 4 19:49:03 build-hppa-1100 vmunix: USB HID: Device 2 has been reset

Could you please let me know what is remedy for this.

Thanks
Syed Ali
6 REPLIES 6
Highlighted
Honored Contributor

Re: Telnet not working on HP-Ux 11.00 PA-Risc

With an OS this old and a ioctl failed message it could be just about anything. Ever odder that you have USB devices enabled.

Where to start ?
Do you at least have the last set of patches for 11.0 ?

Did this just start happening or is this a new issue on a server that has been working ?

Is your network stack working ? can you telnet from this server to another ?

Do other services work, i.e. ftp ?

Highlighted
Honored Contributor

Re: Telnet not working on HP-Ux 11.00 PA-Risc

Highlighted
Advisor

Re: Telnet not working on HP-Ux 11.00 PA-Risc

Three days back this I_LINK_DEV ioctl failed error message is started from their onwards user are not able to login by using telnet.

USB HID: Device 2 has been reset is comming from long time.


Highlighted
Regular Advisor

Re: Telnet not working on HP-Ux 11.00 PA-Risc

LINK_DEV ioctl fail is most likely wrong major number for telnet device special file. "insf -e" should recreate them with proper major numbers and telnet should work fine after that.

--vishwas.
Highlighted
Honored Contributor

Re: Telnet not working on HP-Ux 11.00 PA-Risc

Hi Syed,

Did you install any patches lately ?

Here is the cause,

Telnet patches are comprised of telnet kernel and telnetd components.
If,for example,the kernel rebuild failed or the system was not rebooted after the Telnet patch installation,then the Telnet patch
is only partially installed and the telnet kernel and telnetd user
space components may now be incompatible.

To correct this problem,use swremove(1M)to remove the partially
installed Telnet patch and then re-install it again using
swinstall(1M).Refer to the Telnet patchdocumentation to verify
that the patch is correctly installed.

WK
Problem never ends, you must know how to fix it
Highlighted
Advisor

Re: Telnet not working on HP-Ux 11.00 PA-Risc

Yes some one try to install SSH on this box after that telnet service is not working

# swlist -l product | grep -i telnet
PHNE_14820 1.0 telnet(1) patch
PHNE_16546 1.0 telnet kernel patch
PHNE_18527 1.0 telnetd(1M) patch
PHNE_26096 1.0 telnet kernel and telnetd(1M) patch
#

Could you please let me know what steps i have to take here onwards.

Thanks
Syed Ali