HPE EVA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

 
Highlighted
Occasional Advisor

4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

Hello folks,

I've located 5.1.1b firmware, but can't get our 4/16 switch to install it.

Using username "admin".
admin@fsw02.garf.private's password:
FSW02:admin>
FSW02:admin>
FSW02:admin> disableswitch
rbash: disableswitch: command not found
FSW02:admin> switchdisable
FSW02:admin> firmwaredownload
You can run firmwareDownloadStatus to get the status
of this command.

This command will cause the switch to reset and will
require that existing telnet, secure telnet or SSH
sessions be restarted.

Do you want to continue [Y]:
Server Name or IP Address: 10.100.0.14
User Name: ftp
File Name: /v5.2.1b/release.plist
Password:
Firmwaredownload has started.
Start to install packages......
dir ##################################################
ldconfig ##################################################
error: /tmp/rpm-4464/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
error: /tmp/rpm-4464/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
error: /tmp/rpm-4464/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
error: /tmp/rpm-4464/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
Firmwaredownload failed. (0x2b) Failed to install RPM package.
FSW02:admin> firmwaredownload
You can run firmwareDownloadStatus to get the status
of this command.

This command will cause the switch to reset and will
require that existing telnet, secure telnet or SSH
sessions be restarted.

Do you want to continue [Y]:
Server Name or IP Address: 10.100.0.14
User Name: ftp
File Name: /v5.1.1b/release.plist
Password:
Firmwaredownload has started.
Cannot download ftp://ftp:@10.100.0.14//v5.1.1b/SWBD34/release.plist.
Firmwaredownload failed. (0x12) Cannot access package list (.plist) file.
FSW02:admin> firmwaredownload
You can run firmwareDownloadStatus to get the status
of this command.

This command will cause the switch to reset and will
require that existing telnet, secure telnet or SSH
sessions be restarted.

Do you want to continue [Y]:
Server Name or IP Address: 10.100.0.14
User Name: ftp
File Name: /v5.1.1b/release.plist
Password:
Firmwaredownload has started.
Start to install packages......
dir ##################################################
ldconfig ##################################################
error: /tmp/rpm-4641/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
error: /tmp/rpm-4641/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
error: /tmp/rpm-4641/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
error: /tmp/rpm-4641/glibc-2.1.3-6.ppc.rpm cannot be installed
Failed to install Package glibc-2.1.3-6.ppc.rpm. Retrying ...
Firmwaredownload failed. (0x2b) Failed to install RPM package.
FSW02:admin> version
Kernel: 2.4.19
Fabric OS: v5.0.1b
Made on: Wed Aug 17 21:28:18 2005
Flash: Tue Feb 7 19:43:27 2006
BootProm: 4.5.2
FSW02:admin> switchenable
FSW02:admin>

Currently on 5.0.1b, running kernel 2.4.19.

It looks like 5.3.x moves to a 2.6 kernel, which is quite a leap for a "minor" upgrade from 5.2.x.

Is anyone able to help with the above error? Are Brocade and IBM firmware zip files okay to use on an HP branded 4/16? Haven't had any luck getting 5.2.x or 6.0.x from HP yet.

Many thanks in advance.

--Gandalfje
9 REPLIES 9
Highlighted
Honored Contributor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

Hi,

You should be able to go from a 5.0 release to a 5.1 release...

You can get a "HP" 5.1 version here, to see if that makes any difference:

ftp://ftp.hp.com/pub/softlib/software7/COL15014/co-39912-1/v5.1.0.zip

Hope this helps,

Regards,

Rob
Highlighted
Occasional Advisor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

Thanks Rob - already had this download from another thread. Same error as above using this zip package.

--Gandalfje.

Highlighted
Honored Contributor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

Hi,

It's been a while since I've done a firmware upgrade, but I'm wondering if it's failing due to lack of space somewhere...

Have there been previous upgrades in the past that might be lying around ?

Cheers,

Rob
Highlighted
Occasional Advisor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

No idea Rob - how would I find out?

Is there a way of getting a shell prompt?

I am "Linux enabled" ;-)

I may need to get there anyway if I have to "tweak" this switch and force it to obey!

Config isn't important to me, it's just a lab switch. It is a PowerPak, so I don't want to lose the licences, but that's all I care about.

Thanks.
Highlighted
Honored Contributor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

This customer advisory deals with cleanups (needs login from the "root" user):

c01948592 - HP StorageWorks B-Series Switches - "supportsave -r" Fails

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01948592

(Not sure if it really helps or what the problem is, but you could give it a try)


> ...I don't want to lose the licences

The "licenseShow" command will give you all keys.
.
Highlighted
Occasional Advisor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

Thanks Uwe.

I've got the keys stored safely - I am concerned they may be related to keys/certificates generated for "this" incarnation of FOS, and a bare metal recovery would invalidate them. If they are related to the serial/product ID, then it's all fine of course.

I'll give the "customer recovery" procedure a bash today.

Many thanks.
Highlighted
Honored Contributor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

As far as I know, the keys are only bound to the switch's WWN.
.
Highlighted
Occasional Advisor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

Right - I'm logged in as root, and only using 69% of the 118M /dev/root device.

Is there a way to attempt the upgrade from the root prompt?

I may be able to decipher what's going on from RPM logs.

Thanks.
Highlighted
Occasional Advisor

Re: 4/16 v5.0.1b Firmware upgrade "rpm cannot be installed"

AAAAARGH!

My FTP server (Cerberus FTPD to name the culprit) had a default option of "optimise transfers for Windows NT and above".

Disabling this made all my firmware packages begin to work!

Strange that ldconfig and dir worked, and it only gorp'd on glib (bigger).

Sorry to have troubled you all. Many thanks for the assists along the way.

--Gandalfje