HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Questions Regarding HPE OneView 5.2 Gen9/Gen10 Firmware Requirements

 
SOLVED
Go to solution
Highlighted
Frequent Visitor

Questions Regarding HPE OneView 5.2 Gen9/Gen10 Firmware Requirements

We are currently running a mixture of 5.00.02 and 5.00.00.02 in our environments and are very interested in the fixes contained in the 5.2 release. We have (like many) experienced the firmware update/update from template issues with the 2019.12.0 and 2020.03.0 SPP releases. We are seeing the issues when using the combined Gen9/10 SPPs. But either way items that were address via HPE support through patching (Hitesh in L2 was great for that assistance). 

That being said, did want to pose to the community some concerning statements in the 5.2 support matrix document: https://support.hpe.com/hpesc/public/docDisplay?docId=a00095891en_us

Looking at page 8-9, it appears the firmware requirements for managed systems for OV 5.2 compatibility have gone up significantly. As an example, it states: 

Table 2: Minimum firmware version required for discovery of devices 

and

Table 3: Minimum firmware version required for active management, monitoring, and migration

The levels cited for Gen10 for example are 2.10. Gen9 is 2.0. I'm focusing in more on the Gen10 requirement and the wording of these statements. If taken literally, it would appear to me that we could update to 5.2 and then all of our Gen10 systems would not be discovered or even worse, would no longer have active management or monitoring? If you look at the OneView 5.0 support matrix, the firmware levels are much lower for the Gen10, so a non-issue. 

My question is we have systems that simply cannot be brought up to 2.10 (keeping items running older versions of OS with it's paired SPP, or whatever the case may be). Can we not update to 5.2 until a user can confirm that every single systems on the appliance is at 2.10? 2.10 was contained in the 2019.12.0 SPP, so it's just a much higher level of firmware and I've got to image many customers outside of myself have Gen10 systems in produciton today that are NOT at the SPP or iLO level. What impacts or concerns would we face if we updated our OneView appliance to 5.2? Thanks again!

5 REPLIES 5
Highlighted
HPE Pro

Re: Questions Regarding HPE OneView 5.2 Gen9/Gen10 Firmware Requirements

Hi There,

yes , you read it correct. You will have to have the Minimum firmware version on all your server if you want to deploy Oneview appliance 5.2.To add a device to the appliance and actively manage, the devices must meet the minimum firmware requirement as mentioned in HPE OneView 5.2 Support Matrix.

You might face profile issues , misreporting issue and also servers might not get added to appliance and may lead to many other problems.

Cheers.

I am an HPE employee
Accept or Kudo
Highlighted
HPE Pro

Re: Questions Regarding HPE OneView 5.2 Gen9/Gen10 Firmware Requirements

Keep in mind you also have the option to independently upgrade just the Gen iLO5 v2.10 outside an SPP.  This provides a path that does not disrupt the workload on the server while meeting minimum firmware requirements.

I am an HPE Employee
Accept or Kudo
Highlighted
Frequent Visitor

Re: Questions Regarding HPE OneView 5.2 Gen9/Gen10 Firmware Requirements

Thank  you to both the HPE employees that have responded. Completely understand that we can independently update iLOs. I think the concern is that in large environments (hundreds or thousands of systems) - that is quite a pre-requisite task in order to update to 5.2 to take advantages of those appliance fixes. Either way, we will take the answers here and go forward. I think the point we only wanted to make is that the OV 5.0 support matrix lists 1.10 as the minimum iLO 5 version and 5.2 made a significant jump to 2.10 being the minimum version.  For what it is worth - we did test an appliance update from 05.00.02 to 05.20.01 with Gen10 iLOs at 1.40 and appeared to show no issues. But as someone earlier menitoned, if we see odd things - could be due to the iLO firmware. Thank you for the feedback!

Highlighted
HPE Pro

Re: Questions Regarding HPE OneView 5.2 Gen9/Gen10 Firmware Requirements

Your message has been heard and your concern is duly noted.  You have triggered an engineering inquiry into why that specific decision was made so that we can ensure it has a strong justification.  Otherwise it will be revised.

I am an HPE Employee
Accept or Kudo
Highlighted
HPE Pro
Solution

Re: Questions Regarding HPE OneView 5.2 Gen9/Gen10 Firmware Requirements

The OneView 5.2 support matrix is being updated to revert specific versions that were updated in error.  Please watch that document for an update, the review is not yet completed.

I am an HPE Employee
Accept or Kudo