HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Update Logical interconnect from LIG

 
Highlighted
Occasional Contributor

Update Logical interconnect from LIG

We are trying to add new VLAN to existing uplink set, however we receive the following error:

For uplink set FAB1_UL_VM, Load Balance mode will be updated from SourceAndDestinationMac to None.
For uplink set FAB2_UL_VM, Load Balance mode will be updated from SourceAndDestinationMac to None.
For uplink set FAB1_UL_Phy, Load Balance mode will be updated from SourceAndDestinationMac to None.
For uplink set FAB2_UL_Phy, Load Balance mode will be updated from SourceAndDestinationMac to None.
Network(s) NET_VLAN10 will be added to uplink set NET_UL_Phy.

  • Will performing the action "update from group" from group cause full outage across both modules simultaneously or will they update odd/even/serial?
  • Will manually editing the LI to match the group cause any different outage to performing the above action?
  • Why is load balance mode changing, I cannot see anywhere to set option on LI / LIG?

 

Versions of Firmware:

OneView 4.20.01.01
C7000 OA 4.80
2x HP VC Flex-10/10D Module V4.62
2x HP VC 16Gb 24-Port FC Module V3.09

 

Many thanks,

Mark

6 REPLIES 6
Highlighted
HPE Pro

Re: Update Logical interconnect from LIG

Will performing the action "update from group" from group cause full outage across both modules simultaneously or will they update odd/even/serial?

Adding a new VLAN to an existing uplinkset in the LIG would not cause any outage but however updating LI from the Group might have a temperory Disruption which will recover back automaticaly.(Recomended to do on a maintenance window)

Please refer to the link below for virtual connect traffic flow ,

https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-c03154250

Will manually editing the LI to match the group cause any different outage to performing the above action?

At LI Level we cannot manualy update or make any changes. as the settings would be applied from its group settings(LIG).

Why is load balance mode changing, I cannot see anywhere to set option on LI / LIG?

In LIG when configuring the Uplink set, there is an option called Connection Mode which is set to Automatic(which is LACP mode). It depends on the external Switch LACP mode. If a port trunking is enabled on external Switch VC ports, then it would be Trunked otherwise not.

kiranm
I work for HPE

Accept or Kudo

Highlighted
Frequent Advisor

Re: Update Logical interconnect from LIG

@CISpecialist- in your reply above you note "In LIG when configuring the Uplink set, there is an option called Connection Mode which is set to Automatic", but that is only true for Ethernet type Uplink sets - not FC uplink sets, and even with Ethernet uplink sets there is no option to change this Load Balancing to "None" as the LIG inconsistency error message reported by @mdcp indicates that it is going to do.

SUS_Ethernet_no_LoadBalancing_setting_for_None.jpg

But importantly, the 'Connection Mode' and 'LACP Load Balancing' options do not appear at all for Fibre Channel type Uplink Sets;  at least they do not for mine (labeled FC-A in the image below) and I'm assuming the same is true for @mdcp - although I am making an assumption based on the FAB prefix of the SUS's listed in his error message that those are Type Fibre Channel as well.

SUS_EFC.jpg

And so I have the same questions, why am I getting an error about the Load Balancing mode changing for my Type Fibre Channel Uplink Sets when adding a new network to my Type Ethernet uplink sets?  This is the first time I am adding a new network to my Type Ethernet uplink sets after upgrading OneView to v 5.00.02-0418011 - I have never gotten this error message when adding new networks under prior OneView versions.  I suspect that either the default Load balancing method SourceAndDestinationMac for Type Fibre Channel Uplinks has changed in this version, OR this version is now enforcing a recognition that SourceAndDestinationMac Load Balancing does not really apply to FC uplinks and it sees the current load balancing setting of SourceAndDestinationMac on the FC Uplinks (even though that not visible in the OV GUI) as not valid and wants to change it to None? AND is following the OneView recommendation that "The logical interconnect can be made consistent with its logical interconnect group via update from group."  going to cause any kind of outage or blip?  I'm more concerned about an interruption in FC connectivity than network connectivity.

Any further information you can provide on this topic would be appreciated.

Thank you,

Patrick

Highlighted
Occasional Contributor

Re: Update Logical interconnect from LIG

Thanks for your reply @PatrickLong exactly what I was getting at.

 

I logged a job over three weeks ago Ref: 5347716749  for the above and have not had a reply in over two weeks, very poor support from HPE. 

 

Highlighted
Frequent Advisor

Re: Update Logical interconnect from LIG

 @DanCernese  @ChrisLynch Do you or anyone from HPE know what could be causing this? No one from HPE nor any community members have offered any thoughts to date, and this thread has 700+ views so I think there's some interest.  It seems like a change in newer versions of OneView as it's happening when I try to add a new network to the LIG on both my OneView appliance vm managing c7k'chassis as well as my OneView Composer managing Synergy frames. 

SUS-FC changes during network add to SUS-network.jpg

Again I'll ask - is following the OneView recommendation that "The logical interconnect can be made consistent with its logical interconnect group via update from group."  going to cause any kind of outage or blip?  I'm more concerned about an interruption in FC connectivity than network connectivity.

Highlighted
HPE Pro

Re: Update Logical interconnect from LIG

Appologies.  Some of the forum emails get lost from time to time, and obviously missed your posts.  I am not sure why you get that message.  I will ask around internally and provide a reponse soon.


I am an HPE employee

Accept or Kudo

Highlighted
HPE Pro

Re: Update Logical interconnect from LIG

After some discussions with R&D, this is supposed to be a "NO-OP" operation.  Meaning, no downtime should be experienced.  I would suggest however, that this operation be done during non-peak hours, as a precaution.

Also, this issue was seen similarly in older 4.x versions, and fixed in 4.20.  A small regression was introduced in 5.00 and is fixed in 5.20.  There are more improvements with the Update From Group message in the recently released 5.30, and we have some additional enhancements (mainly around the remediation message and its guidance) coming in another update.


I am an HPE employee

Accept or Kudo