IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

iMC 7.3 E0605P06 upgrade E0703 or E0705 fails

 
SOLVED
Go to solution
Highlighted
Occasional Collector

iMC 7.3 E0605P06 upgrade E0703 or E0705 fails

Hi,

I have Red Hat Entreprise Server 6.1 and I want to upgrade iMC to E0705

iMC is standalone it's E0605P06 version

DMA starts and after the check of components to upgarde DMA is closed automaticaly (in spite of starting the upgarde procdure)

2020-03-03 16:43:42 [ERROR] [main] [com.h3c.imc.deploy.Util::setDefaultLookAndFeel(2010)]
java.lang.InternalError: Unable to load native GTK libraries
at java.desktop/com.sun.java.swing.plaf.gtk.GTKLookAndFeel.initialize(GTKLookAndFeel.java:1421)
at java.desktop/javax.swing.UIManager.setLookAndFeel(UIManager.java:586)
at java.desktop/javax.swing.UIManager.setLookAndFeel(UIManager.java:633)
at com.h3c.imc.deploy.Util.setDefaultLookAndFeel(Util.java:2007)
at com.h3c.imc.deploy.CommonComponentUpdateLauncher.main(CommonComponentUpdateLauncher.java:85)
2020-03-03 16:43:43 [INFO ] [main] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::checkEnv(184)] instJavaHome: /root/Downloads/iMC_PLAT_7.3_E0703_Standard_Linux/linux/install/common/jre_linux64
2020-03-03 16:43:43 [INFO ] [main] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::checkEnv(185)] instJavaHome.exists(): true
2020-03-03 16:43:43 [INFO ] [main] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::checkEnv(186)] instJavaHome.equals(javahome): true
2020-03-03 16:43:43 [INFO ] [main] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::checkEnv(190)] javahome: /root/Downloads/iMC_PLAT_7.3_E0703_Standard_Linux/linux/install/common/jre_linux64
2020-03-03 16:43:43 [INFO ] [main] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::checkEnv(216)] hello run command cat /etc/redhat-release
2020-03-03 16:43:43 [INFO ] [main] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::checkEnv(222)] version:Red Hat Enterprise Linux Server release 6.1 (Santiago

I need help, is my os too old ?

Thks,

Cyrille

1 REPLY 1
Highlighted
HPE Pro
Solution

Re: iMC 7.3 E0605P06 upgrade E0703 or E0705 fails

Hello,

That's correct, the OS is outdated and no longer supported on the new versions. This is largely due to the JDK change in iMC on 7.3 E070x versions, moving from Oracle JDK 7 to OpenJDK 11, which no longer supports some older OS releases. Please check the Release Notes for E0705 under Installation Prerequisites:

https://support.hpe.com/hpsc/doc/public/display?docId=a00093380en_us

It is possible to migrate your existing installation to the newer OS. Migration Guides for Windows and Linux are included in the "manual" folder of the latest iMC E0705 download archive.

Downloads: https://h10145.www1.hpe.com/downloads/SoftwareReleases.aspx?ProductNumber=JG747AAE

Hope that helps.

Best regards,
Justin

Working @ HPE
Accept or Kudo