cancel
Showing results for 
Search instead for 
Did you mean: 

Linux Bonding with mode=1

 
Highlighted
Advisor

Linux Bonding with mode=1

Hi,
I successfully configured linux bonding on RHEL 5.5 on HP BLade 460c G6. I am also using RHCS. I cannot lose a single ping drop when I powered off my blade switch but my ssh session has been dropped.I am using below parameters in /etc/modprobe.conf.
alias bond0 bonding
options bonding mode=1 miimon=100 downdelay=200 updelay=200 max_bonds=1 primary=eth0
I am worry about, If my ssh session has been dropping in case of switch powering. So Is there any effect on cluster nodes if there is any network link distrubance? If both the node lose the network connectivity then surely cluster will fence the nodes. Am I Right?
Please help me.
Regards
/Athar
2 REPLIES 2
Highlighted
Honored Contributor

Re: Linux Bonding with mode=1

Any problem with your cluster interconnect will produce fencing. You should not lose your ssh session.

Check your configuration options, check also the kernel bonding documentation, ensure that you want to use miimon to monitor the link:

http://www.cyberciti.biz/howto/question/static/linux-ethernet-bonding-driver-howto.php

If you have to use miimon, then reduce the values to:

miimon=50 downdelay=100 updelay=100
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Highlighted
Honored Contributor

Re: Linux Bonding with mode=1

cat /proc/net/bonding/bond0 and make sure that the bond configured as you intended.

this may not make s difference but, I found that putting the bonding options in the ifcfg-bondx configuration file seems to be more reliable than in modprobe.conf