ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Did you mean: 

c:\hpssbem.exe is not a valid win32 application when setting up Windows Small Business Server 2011

Occasional Collector

c:\hpssbem.exe is not a valid win32 application when setting up Windows Small Business Server 2011



Just to give you a quick background, I have a good bit of experience building PCs but I am generally a newbie when it comes to servers, however am very eager to learn.


I have bought a new HP ProLiant ML110 G7 server with 12gb of RAM.  I am planning to run this server in a small office and decided to go with Windows Small Business Server 2011.  However I an having a few installation problems.


I started by running the SmartStart CD (its version 8.70).  As Im looking to run Server 2011 I picked the x64bit disc.  The SmartStart CD loads up and I use the menu to select to install Microsoft Windows Small business Server 2011 x64 standard edition under the general retail media, as the disc isn’t HP OEM version.


I ask it to install from a DVD and select the standard folder.  I then choose the max partition size on the 250GB SATA drive that came with the machine.  I complete the product information entry ie computer name etc, install the SNMP and PSP which are recommended.  The system then partitions the disk and starts to load the drivers.  At around 27% it spits out the SmartStart CD and I insert the Windows Server 2011 disc.  It recognises the disk and runs through the installation.  The machine then reboots.


Following the reboot the windows server installer starts up, however it never finishes.  After the loading files progress bar finishes I see a desktop background and a smaller command prompt window.  In the command prompt window which says...





then a popup windows comes up saying "c:\hpssbem.exe is not a valid Win32 application"


Whe i click ok, Access is denied appears under the line x:\windows\system32>c:\hpssbem.exe and a new x:windows\system32>" prompt is displayed.


I have no option but to reboot and try again.  When I do I get the same result.


I tried to install direct via the Windows DVD, but that when the windows installer loads up I only get the option to upgrade (which doesn’t work) or repair.  When the repair install starts it copies the install files over in a sec (prob as it detects there have already been copied over by the smartstart install).  However it isn’t able to expand the files - it sits at 0% for ages then reboots.


I have read elsewhere about updating the ROM, however I am on the latest version (J01 05/20/2011) and tired using the Smart Update Firmware DVD that came with the machine. 


Does anyone have any ideas as to how I can overcome this?  Any assistance would be greatly appreciated!



Occasional Collector

Re: c:\hpssbem.exe is not a valid win32 application when setting up Windows Small Business Server 20

Just a quick update


I found on another forum that you might be able to solve this by


"click OK and you will be left at the command prompt. The problem I discovered is that the hpssbem.exe file is 0 bytes... empty. I inserted the smart start CD and from the console window I copied the correct 64-bit file (...\compaq\install\w2k8...\hpssbem.exe)from the smart start CD to the C: drive on the server, then executed the hpssbem.exe program again from the command line"


I followed the above and copied the hpsbem.exe.  It wasnt located in the same folder as stated as this was for windows server 2008.  I was able to find the .exe in "...\compaq\install\w2k8x64"


After copying the file the windows installer loaded up.  The copying moved quickly as before but this time it started to expand the windows files!!


As I type this it has expanded 20%, so I will let you know how I get on after.

Occasional Advisor

Re: c:\hpssbem.exe is not a valid win32 application when setting up Windows Small Business Server 20

Hi all,


See the link posted above as I added to that other message thread what I had to do to work around the same error - just a slight variant to what was done here.  The above is correct - if the hpssbem.exe file on the CD is not corrupt - mine somehow was so I had to do some other things.



New Member

Re: c:\hpssbem.exe is not a valid win32 application when setting up Windows Small Business Server 20

HP Proliant DL385 G7 – HP Smartstart 8.70 & 8.70B – USB Pen – hpssbem.exe (64bit)


If it helps anyone looking for a slightly different approach....


This didn’t work for me. I had a DL385 G7, I downloaded latest version of HP Smarstart DVD 8.70B but still the same issue. I couldn’t find a compaq folder on this DVD 8.70B and for those who are not great with the cmd line this is how i fixed it a GUI. I clicked ok on the error (this is not a valid win32 application) .


I put in the HP Smarstart DVD 8.70 that came with server into my laptop and copied the 64bit hpssbem from the DVD onto a usb pen drive (E:\compaq\install\w2k8x64\hpssbem.exe to F:\hpssbem.exe).


Then back on the server at the cmd line I typed "notepad.exe" hit enter - using notepad as GUI interface (file - open) I renamed the hpssbem on C:\ to hpssbem1.exe.


I then copied the 64bit version directly from the usb pen drive onto C:\ closed notepad typed "exit" on cmd line. The server should automatically reboot.


The server should now complete the install and copies the files it needs from the Windows 2008 R2 SP1 DVD. hope it helps. Trevor