ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL160 Gen10 - Debian 10 UEFI install warning

 
SOLVED
Go to solution
Highlighted
Occasional Visitor

DL160 Gen10 - Debian 10 UEFI install warning

Hi,

Succesfully installed my first HPE server yesterday. Although booting from the default Debian USB installer didn't work, the ISO could be uploaded via iLO perfectly.

At the end of the Debian 10 installation (during install of grub), I did receive a warning along the lines of

it looks like there may be existing operating systems already
> + installed on your computer using 'BIOS compatibility mode'. If you
> + continue to install Debian in UEFI mode, it might be difficult to
> + reboot your computer into any BIOS-mode operating systems later.

I chickened out and installed grub instead of grub-efi to not lose access to any of the HPE utilities offered during POST/boot.

I would prefer installing grub-efi and am considering re-starting just for this. Does anybody know (1) if this will effectively block access to certain HPE applications (the warning seems to imply that this is not certain), and (2) if so, which applications this may be? If it's only the storage application, I can get by with the utilities in the Linux SDR...

Thx!

3 REPLIES 3
Highlighted
HPE Pro

Re: DL160 Gen10 - Debian 10 UEFI install warning

Hi @VincentVH ,

Is this a fresh installation, or was there any Operating System installed earlier.

Looking at the "message" it looks like there was an OS installed already and if you proceed installing on UEFI Mode, you would not get any issues. And the Boot mode should be set as "UEFI Mode".

Will share more information once I get any.

Thank you


I work for HPE

Accept or Kudo

Highlighted
Occasional Visitor
Solution

Re: DL160 Gen10 - Debian 10 UEFI install warning

Thank you, @ksram for your reply.

This warning was shown by the Debian installer the very first time I ran the installer, so there was no OS installed. Because of that warning, I chose to proceed with the install to the MBR (/dev/sda) and changed the machine's bios to boot in BIOS mode instead of UEFI mode.

I then decided to take the risk, and (1) reverted my changes to the machine's bios to again boot in UEFI mode, (2) re-ran the Debian installer and "lo-and-behold": the warning was not shown. Subsequently, I created an EFI partition next to the other partitions and successfully installed Debian 10 (Buster) in UEFI mode.

I have not yet encountered any downsides, but I must admit that, other than the general bios and iLO settings, I haven't touched any of the other applications (I don't need the smart storage controller application e.g.).

Hope this helps someone down the road.

Highlighted
HPE Pro

Re: DL160 Gen10 - Debian 10 UEFI install warning

Hi @VincentVH ,

Thank you very much!

Much appreciated!


I work for HPE

Accept or Kudo