ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Did you mean: 

HP Smart Update Discovery failed

Occasional Contributor

HP Smart Update Discovery failed


We have 5 ML 350 G5, I update the latest Firmware CD 8.20 and PSP 8.10 on 4 servers, but on one ML 350 G5 I receice message : HP Smart Update discovery filed and pplication popup: hpsum_discmgr.exe - Application Error : The instruction at "0x00506432" referenced memory at "0x00000000". The memory could not be "read". How to view HP smart update log file and correct problem.
Trusted Contributor

Re: HP Smart Update Discovery failed

you can find the log here.

%TEMP%\hp_sum directory

Also Try to Clear all the temp files and then use BPXXXXXX.CMD file which is provided with the Support Pack for use in installing the Support Pack from a command prompt without user interaction.

As with the HPSUM.EXE program, all software appropriate for the system it is being run on will be installed.

New Member

Re: HP Smart Update Discovery failed

I am having this same issue, and have been fighting with this for a couple days.


I can not run HPSUM locally, discovery fails.  I can not run the batch file, every single individual installer fails.  I can not run an individual update using the "install" button, it immediately fails.  I can not run HPSUM remotely, discovery fails.


I have succesfully boot from the firmware update CD and isntalled all available firmware updates.


I can install  individual updates if I choose "extract" first and then install them from the extracted files.


I had an inventory problem on a different server because of a storage controller (fibre HBA).  I tried disabling the HBA on this server, but no luck with that either.


I was able to run a PSP update a few months back succesfully, so not sure what is different now.  This is my HP ICE server as well, but even with all services stopped, still no success.  And nothing of any use in written to any logs.


Any idea's?




EDIT.  I am trying to run PSP version 8.70, but I tried going back to older versions, and I get the same issue.