ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

 
SOLVED
Go to solution
Highlighted
Honored Contributor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

.

 




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
Acclaimed Contributor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

Thank you, but the question is how to find it if I don't have the direct link from you?

 

I looked under several servers with ILO3 and 1.57 is always the latest.

 

 

 

 

I was trying from this page too:

 

http://h18013.www1.hp.com/products/servers/management/iloadv3/index.html


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Highlighted
Collector

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

If you click on the link for the Update itself (The text on the left)  or on the 1.57 link or even the older 1.55 version, you are then taken to the page to download it.      From there,  click Revision History and scroll down until you find 1.28(B) and click THAT link (1.28 is a hyperlink).   

 

Here's the Link to the page with the 1.28 (B) download that worked for me.    If that doesn't work,   do a google search for cp016892.exe and the first result will send you to the site i linked above.

 

I just had to do this as we had some that were still on 1.10 and 1.16 and could not figure out why I couldn't update to 1.65     

Glad I found this post about needing to go to 1.28 first.

 

Brian

 

Highlighted
New Member

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

I also had this issue. It happened after I tried to update the iLO settings through the HP Lights-Out Online Config Utilitiy Windows tool. After disconnecting both power supplies for about a minute, then booting back up, I was able to then configure the iLO through the HP Lights-Out Online Config Utilitiy. However, it gave an error again and did not make the changes.

 

After about 2 hours of troubleshooting I fixed the issue. The iLO firmware version was too old to be updated through the Windows Utility I was using. The firmware version was 1.07 (I think). I was able to update the IP of the iLO through the Pre-boot environment (F8). I also followed this guy's [ http://youtu.be/domrAka9BNI ] advice and disabled the Power logo first. Not sure if it helped or not, but that's what I did. 

 

I then connected through the WebGUI and updated the firmware.

 

If you are using an iLO firmware before 1.28, you MUST update to 1.28 first. Otherwise it will just time-out or not flash at all. I flashed from 1.07 >> 1.28B. Then I flashed from 1.28B >> 1.80. Even after all of that I still got an error with the Windows tool. This time it was more helpful and said invalid link speed. I disabled the auto speed setting and set it to 100. Now I was able to update through the Windows tool. For giggles, I switched it back to auto, and everything is still working.  I suppose this could have been the problem all along (as opposed to firmware mismatch). Possibly if I would have just switched the link speed in the beginning it would have worked, but the previous firmware did not give informative error messages.

 

Hope this helps someone.

 

Highlighted
Visitor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

Yes, flashed to 1.28 then on to 1.87 with no further proplem.

Kudos!!

Highlighted
Advisor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

Just a quick look: iLO 3 V 1.88 FW has a problem - iLO watchdog reset without any rule on all servers.

Revert to 1.87 and everything is fine.

 

Professional Hosting Services
Highlighted
Occasional Visitor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

I do have the same issue on G7 Blades and ProLiant servers. Flashing from 1.87 to 1.88 is fine, however sometimes the iLO is unresponsive for about 10-15 minutes. Ping still works but the Webinterface is unresponsive and cannot be accessed. However a Remote Console session that was opened before still works. After iLO is reachable again a message is logged: "Watchdog reset on Initial, pc 0007c5b8, sp 00524e10"

Please fix this as soon as possible. Can we get a response from a HP employee?

Highlighted
Advisor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

No any valid solution with iLO 1.88 FW.

We have test this firmware on our BL450c Blade Servers - the results is the same.

Hope this should be solved with new FW (if any, in the future).

Professional Hosting Services
Highlighted
Occasional Visitor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

Well the last firmware was released in July 2016. Not sure why HP isn't fixing this. There are known security vulnerabilities so downgrading to 1.87 is not really an option but a crashing iLo isn't either.

It seems like the issue only occurs when the iLO has a public IP. My internal iLOs do not show this behaviour. Maybe it's caused by a port scan on a specific port or something else triggered by probably hacked servers.

Highlighted
Advisor

Re: PROBLEM UPGRADE FIRMWARE ILO 3 on HP PROLIANT DL 380 G7

You are right - on the local (internal) network iLO v1.88 works fine. We have checked all access/error list by public IPs via our firewall - no any port scanner or server hack detected. We also changed https port - use something like 4043 - the result is the same.

Someone from HPE staff - your comments are highly appreciated.

Professional Hosting Services