ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

upgrade NOS on LH3

 
Highlighted
New Member

upgrade NOS on LH3

I have a netserver LH3 w/ 2 PIII 500 Mhz CPUs and 512 MB Ram. I plan to upgrade from NT4 sp6a (member server) to w2k server--not do a clean install. The system is 5-disk RAID 5 w/ 3 partitions; 1) 8GB OS, 2) 25GB data & 3) 1GB page file & print spool. I have read through the doc and forums and prepared the following:
updated rescue disk and downloaded the BIOS, NetRAID firmware and driver, and backplane updates. I do not have the navigator disk, but the forums state this isn't necessary. I have run HP's TopTool and found that all everything is okay. Basically I want to verify the upgrade process.
1) upgrade BIOS & reboot
2) boot using w2k setup disks, not the bootable CD.
3) hit F6 and upgrade NetRAID controller. I believe, from TopTool, I have NetRAID 1. Is there another way to verify this?

Here's where I start getting confused. At hp.com there are these drivers listed under w2k server ( http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?locale=en_US&pnameOID=15389&taskId=135&prodTypeId=15351&prodSeriesId=50440&submit.y=1&submit.x=8〈=en&cc=us&swEnvOID=226 ) and there is cross OS firmware listed at ( http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?locale=en_US&pnameOID=15389&taskId=135&prodTypeId=15351&prodSeriesId=50440&submit.y=1&submit.x=8〈=en&cc=us&swEnvOID=54 ) Do I have to use both? Do I use the Firmware update or the Firmware Storage Controller update? Also when do I upgrade the backplane firmware?

I've looked for step-by-step doc but haven't found anything.

Also, will the page file/print spooler on it's own partition cause any problem?

Lastly, since I'm at RAID 5 will I face any problems loading the OS, due to the files being split amongst the HDDs.

Perhaps these question have been asked and answered, but I found a lot of the older posts had broken links to info.

Your advice very appreciated.


3 REPLIES 3
Highlighted
Honored Contributor

Re: upgrade NOS on LH3

Hi Huts,

If you still have the same problem let me know

regards
Amha Kassa
Highlighted
New Member

Re: upgrade NOS on LH3

An update.

I tried to update the bios. Extracted the update to a floppy and found it doesn't create a bootable floppy. There were, I recall, 4 binaries and no readme file. There is no explanation of the bios disk on its download page. Booted with a DOS bootdisk. Tried to run phlash.exe but it errored out. Tried the other binaries but they weren't appropriate. Decided to research a bit more before forcing the bios. Searching through the ITRC forum for bios-update info. A few posts stated that HP bios update file creates a bootable disk--must have been earlier versions of the bios update. I also booted into the HP tools--F12 at boot as I recall--and found there is a bios update utility installed. However there were no instructions and I cound find no way to load the update from the floppy. Can't understand the purpose of the utility.

Greatest challenge to this whole thing has been the lack of documentation by HP. I'm not adverse to reading doc before moving into less-known areas. Looks like they taking this invent thing to far.
Highlighted
New Member

Re: upgrade NOS on LH3

Well I took the plunge and upgraded today.

Basically this is a post-installation note for anyone else.

I downloaded all the firmware and drivers. I also ran HP's TopTool prior to beginning the upgrade.

TopTool helped me identify what RAID controller I was running.

1) BIOS upgrade. Though the HP site doesn't state so (actually it doesn't state anything about the floppy-creation file), and there are no readme files created on the disk, the floppy created is indeed a bootable floppy provided you have the HP Management partition installed. This part was a bit tricky. I thought that I would need to get into the Management Partition and then direct the BIOS upgrade tool to the floppy. This doesn't happen. The BIOS upgrade tool only discovered the currently installed BIOS firmware. A second reboot, this time with the floppy in the drive, and the Mangement Partition picked up the floppy and ran the BIOS upgrade. Easy? Yes. Well documented? No.

2) RAID controller firmware upgrade. Having learned my lesson from the BIOIS upgrade I let the management partion do the work, and everything went fine. Again poorly documented on the HP site and no Readme file. Here's the goofy part. When I launched the floppy-creation tool I was told it was for an LH4. It actually says so on the dialog box that appears after the binary is executed. Yet, I read the .ini file put on the floppy and it was indeed for an LH3. Who's creating this stuff!??

3) Hotswap backplane firmware upgrade. I didn't believe my box had the hotswap backplane, but TopTool didn't give me good info on this. Booted the box to the backplane floppy. There are two phases. The 1st ran to completion and then the second phase started. Shortly afterward I was informed I didn't have a hotswap backplane. No consequence.

4) I copied the w2k server CD to C: I then launched the install while in NT. I selected the recommended option to upgrade rather than do a clean install. I had all the data backed up to two locations so losing data wasn't a concern. I didn't want to have to import all the user accounts and re-assign/recheck the permissions to the files.

5) Copy phase completed and box rebooted. Here's where I goofed. I was waiting to put in the 2 floppies so that the correct 3rd-party HP drivers would be loaded. But I got distracted and I missed it. Uh-oh. Installation completed. Major worries as I wasn't able to load the NetRAID driver from the floppy. Looked like the NIC drivers were on the floppies also. Uh-oh.
6) Box rebooted and this it was time to
discover mouse & keyboard. A very very long wait. That completed and then the network configuration completed.

7) Box booted to w2k server. Disks running. No errors. An entry in the log about being unable to start the HP NIC service. Nothing missing and shares, user groups, and permissions intact. Have network connectivity. W2K picked up the NIC. Yeah!

8) Installed SP4 & rebooted. At reboot was told that APC UPS software was going to shut down the box. Uh-oh. Rebooted and again it happened. Stopped and disabled the APC services. Uninstalled the APC SmartSuite software. Installed the remain w2k patches.
Rebooted.

9) Clean boot. Installed latest APC SmartSuite. Rebooted and clean again.

10) Running defrag now and will let OS burn in for a few days. Then will mess with my SCSI peripherals. May relook at the NIC drivers.

All in all it went pretty well. The only issue I had was the lousy documentation from HP. This is a box my predecessor bought. Since I've been on the job we haven't bought anything from HP other than its laserjet printers. My decision. Based solely on the poor support. Box I upgraded today will be replaced in 12 months. It won't be a HP (or Compaq) sitting in its spot.