Security
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: where download glibc for HP-UX 11.31

 
SOLVED
Go to solution
Highlighted
Occasional Advisor

where to download glibc for HP-UX 11.31

Hi all,

I need to install the glibc library on HP-UX 11.31

Please, where can I get the packe for download

Thanks

3 REPLIES 3
Highlighted
HPE Pro

Re: where download glibc for HP-UX 11.31

Your requirement is not very clear. In case, you are looking for C/C++ compiler, for development purpose, you need to purchase the license for it. 

However, you can get some archived libraries, compatible with HP-UX 11.31, at the following link :

http://hpux.connect.org.uk/

For any specific requirement, it is advisable to open case with HPE Support Center so that your individual requirement could be addressed.

Best Regards,


I work for HPE

Accept or Kudo

Highlighted
Occasional Advisor

Re: where download glibc for HP-UX 11.31

The backup staff is asking me to install the glibc library because they have a problem trying to integrate an Oracle database with data protector 10.30

The integration is required to restore an Oracle database that was backed up with data protector 10.30 on an HP-UX 11.31 server and is required to restore on a second HP-UX 11.31 serve

When running the DP integration, it displays the following message:
Cannot execute '/opt/omni/lbin/ob2rman.pl' ([13] Permission denied) => aborting
Apparently the above message is due to the lack of the glibc library

Check the libraries installed in HP-UX 11.31 and I found the following one already installed, but I don't know if there is a library for HP-UX with the name glibc
swlist -l patch | fgrep "libc cumulative"
# PHCO_40846 1.0 libc cumulative header file patch
# PHCO_44212 1.0 libc cumulative patch

Additionally the permission of ob2rman.pl are:
ll /opt/omni/lbin/ob2rman.pl
-r-xr-xr-x 1 root sys 140098 Feb 27 2019 /opt/omni/lbin/ob2rman.pl

Can someone please tell me if there is a library named glibc for HP-UX 11.31 ???

Thanks

Highlighted
Honored Contributor
Solution

Re: where download glibc for HP-UX 11.31

> Cannot execute '/opt/omni/lbin/ob2rman.pl' ([13] Permission denied) =>
> aborting
> Apparently the above message is due to the lack of the glibc library

   It's not apparent to me.  How did you decide that that error message
is related in any way to a glibc?

   ".pl" suggests (to me) a Perl script.  I can't see that script.  Does
it specify a Perl executable ("#!")?  Can you execute that Perl program?
Is there a problem with your Perl installation?

> [...] I don't know if there is a library for HP-UX with the name glibc
> [...]

   As the simplest Web search would reveal, glibc is "The GNU C
Library"; it is not part of HP-UX.

      https://www.gnu.org/software/libc/