Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

How to force uninstall of cpq_cciss-3.6.24-4 RPM package?

 
Highlighted
Occasional Contributor

How to force uninstall of cpq_cciss-3.6.24-4 RPM package?

How do I manually force RPM uninstallation of cpq_cciss-3.6.24-4?

I tried the rpm -evh --force cpq_cciss-3.6.24-4 and im getting:

rpm: only installation, upgrading, rmsource and rmspec may be forced

If it ain't broke dont fix it
1 REPLY 1
Highlighted
Occasional Contributor

Re: How to force uninstall of cpq_cciss-3.6.24-4 RPM package?

update 02/18/2011:

After failing to force an uninstall of cpq_cciss-3.6.24-4, i'm trying to "upgrade/freshen" the package instead using:

#rpm -Uv cpq_cciss-3.6.26-5.rhel5.i686.rpm

But the install is checking the kernel version as a prerequisite before installation and it is saying that my running kernel (2.6.18-238.1.1.el5PAE) is not supported.

Here's the exact message i'm getting:

Preparing packages for installation...
The currently running kernel (2.6.18-238.1.1.el5PAE) is not
supported by this rpm. The supported kernels are:

2.6.18-128.1.10.el5
2.6.18-128.1.10.el5PAE
2.6.18-128.1.10.el5xen
2.6.18-128.2.1.el5
2.6.18-128.2.1.el5PAE
2.6.18-128.2.1.el5xen
2.6.18-128.7.1.el5
2.6.18-128.7.1.el5PAE
2.6.18-128.7.1.el5xen
2.6.18-128.el5
2.6.18-128.el5PAE
2.6.18-128.el5xen
2.6.18-164.11.1.el5
2.6.18-164.11.1.el5PAE
2.6.18-164.11.1.el5xen
2.6.18-164.15.1.el5
2.6.18-164.15.1.el5PAE
2.6.18-164.15.1.el5xen
2.6.18-164.2.1.el5
2.6.18-164.2.1.el5PAE
2.6.18-164.2.1.el5xen
2.6.18-164.6.1.el5
2.6.18-164.6.1.el5PAE
2.6.18-164.6.1.el5xen
2.6.18-164.9.1.el5
2.6.18-164.9.1.el5PAE
2.6.18-164.9.1.el5xen
2.6.18-164.el5
2.6.18-164.el5PAE
2.6.18-164.el5xen
2.6.18-194.3.1.el5
2.6.18-194.3.1.el5PAE
2.6.18-194.3.1.el5xen
2.6.18-194.8.1.el5
2.6.18-194.8.1.el5PAE
2.6.18-194.8.1.el5xen
2.6.18-194.el5
2.6.18-194.el5PAE
2.6.18-194.el5xen

Please boot into a supported kernel before installing this rpm
error: %pre(cpq_cciss-3.6.26-5.i686) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping cpq_cciss-3.6.26-5


I have since deleted and cleaned up the old kernels and have been running kernels pushed through by Redhat updates.

My question is:

1. Where can I download the HP supported kernels just so I can upgrade my cpq_cciss drivers to version 3.6.26-5.i686?

2. Does HP recommend NOT TO USE the latest kernel updates that RedHat is pushing through RHN update?
If it ain't broke dont fix it