Showing results for 
Search instead for 
Did you mean: 

SLES 9 & SERVICEGUARD com problem

Occasional Advisor

SLES 9 & SERVICEGUARD com problem

Hi all,

I'm trying to create first cluster, have read (I think) all the posts here, and still have no idea how to avoid this error:

Node is refusing ServiceGuard communication

in cmquerycl command

I have th cmclnodelist, I have checked all the ports, the inetd entries (that was the thread I thought was like me, but still with the same problem after checking inetd in yast tool).

I think te problem should be name resolution, because host or nslookup NODE_NAME outs timeout. I don't see inetd.conf file, this also should be the problem.

Any ideas?????

Exalted Contributor

Re: SLES 9 & SERVICEGUARD com problem

Step 1.

Make sure all lans that Serviceguard may use allow ping between the nodes. I have found in my limited HP-UX SG experience that if there is no ping, a cluster can not communicate or form.

Step 2.

There is an obvious name resolution problem. Your nodes need to be able to communicate to all name servers set in /etc/resolv.conf nslookup and or dig commands need to work. On Linux there should be a xinetd.conf file in /etc/xinetd.d

Steven E Protter
Owner of ISN Corporation
Occasional Advisor

Re: SLES 9 & SERVICEGUARD com problem


I think all is OK, unless the communication.

The OS is SUSE LES 9.0, ServiceGuard 11.16, and the servers are two dl380 with a MSA500. They're only connected with a crossover cable, and isolated from any other network.

The ping works ok, but don't 'host' or 'nslookup'. I think the problem must be the name resolution, but I think I have DNS disabled, (no nameserver o resolv.conf). Does anybody know how can I force the system to use /etc/hosts file???
Honored Contributor

Re: SLES 9 & SERVICEGUARD com problem

First - it sounds like the actual cluster configuration worked corectly. Is that true?

If so, and you get an error message when doing a cmquerycl, cmapplyconf, orcmcheckconf indicating the Serviceguard cannot communicate with a node then usually this means that the firewall is set up incorrectly. Try turning off the firewall temporarily. If that helps then carefully review the firewall settings.

Also, one of the more common problems that people run into now is related to the new security features. You have to read that section of the manual very carefully. More often, this affects your ability to set up the cluster int he first place.

You may want to temporarily allow all users to make sure that this is not part of the problem.
Occasional Advisor

Re: SLES 9 & SERVICEGUARD com problem


problem solved.

The identd daemon wasn't started on boot, so ot didn't work...

Thanks to all for your help