StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

1/8 G2 autoloader & mtx problem

 
SOLVED
Go to solution
New Member

1/8 G2 autoloader & mtx problem

Hi all. Have a problem using 1/8 G2 960 autoloader with mtx command. Just want to perform inventory answ change tapes. The drive works fine, but autoloader not. I've flashed autoloader with new firmware from this month. Only working command is :

# /usr/sbin/mtx -f /dev/sg1 inquiry
Product Type: Medium Changer
Vendor ID: 'HP '
Product ID: '1x8 G2 AUTOLDR '
Revision: '2.60'
Attached Changer API: No

Also more detailed info using loaderinfo:
# /usr/sbin/loaderinfo -f /dev/sg1
Product Type: Medium Changer
Vendor ID: 'HP '
Product ID: '1x8 G2 AUTOLDR '
Revision: '2.60'
Attached Changer: No
Bar Code Reader: Yes
EAAP: Yes
Number of Medium Transport Elements: 1
Number of Storage Elements: 8
Number of Import/Export Elements: 0
Number of Data Transfer Elements: 1
Transport Geometry Descriptor Page: Yes
Invertable: No
Device Configuration Page: Yes
Storage: Data Transfer, Storage
SCSI Media Changer (rev 2): Yes
Volume Tag Reader Present: Yes
Auto-Clean Enabled: No
Transfer Medium Transport: ->Data Transfer, ->Storage
Transfer Storage: ->Data Transfer, ->Storage
Transfer Import/Export: None
Transfer Data Transfer: ->Storage
Exchange Medium Transport: None
Exchange Storage: <>Data Transfer, <>Storage
Exchange Import/Export: None
Exchange Data Transfer: <>Storage

If I try anything else, i get error messages. Ive googled mor many days and found noting. Tryed using amanda, bacule, etc to change the tapes, but didnt work either. Could you please check the error output and try to find out the solutin? THX

# /usr/sbin/mtx -f /dev/sg1 status
mtx: Request Sense: Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=70 (Current)
mtx: Request Sense: Sense Key=Not Ready
mtx: Request Sense: FileMark=no
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=no
mtx: Request Sense: Additional Sense Code = 04
mtx: Request Sense: Additional Sense Qualifier = 8E
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=no
mtx: Request Sense: SKSV=no
READ ELEMENT STATUS Command Failed
# /usr/sbin/mtx -f /dev/sg1 inventory
mtx: Request Sense: Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=70 (Current)
mtx: Request Sense: Sense Key=Not Ready
mtx: Request Sense: FileMark=no
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=no
mtx: Request Sense: Additional Sense Code = 04
mtx: Request Sense: Additional Sense Qualifier = 8E
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=no
mtx: Request Sense: SKSV=no
Initialize Element Status (0x07) failed
mtx:inventory failed

2 REPLIES 2
Highlighted
Honored Contributor
Solution

Re: 1/8 G2 autoloader & mtx problem

That sense data means "NOT READY, SEQUENTIAL MODE" - no motion commands are accepted when the library is in sequential mode.

The default mode is auto-detect which means that if a motion command is accepted then run in "Random" where tapes aren't automatically unloaded but automatically unload tapes if no motion commands are received.

You need to go to the front panel and set your library in Random or Autodetect mode.
Highlighted
New Member

Re: 1/8 G2 autoloader & mtx problem

Thanks very much. It was the problem. I've changed the configurationand it works. Only thing that still does not work is inventory command. It makes no output. But "status" gives me a slots/drive content, so its fine enought. Thnaks again for your help.