StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Re: 1760 SAS Rackmount Not Detected In RHEL6.1


1760 SAS Rackmount Not Detected In RHEL6.1

Hello Forum Land,


I am having problems with a rackmount tape drive (connected by SAS cable) not being detected in RHEL 6 Update 1.


RHEL6.1 x86_64

    Kernel 2.6.32-131.0.15.el6.x86_64

HP DL380 G7 

    HP 1760 SAS 1U Ultrium Rackmount Tape Drive

    HP P212 SAS adapter – Firmware 3.66


I have already tried the following:


1. Rebooted server with tape drive attached, powered on with a tape inserted.

2. Manually loaded modules st, sym53c8xx and aic7xxx.

3. Updated the server to all latest firmware using HP Smart DVD 9.30.

4. Installed HP tape and library tools (hp_ltt package). This gives the error "L&TT does not support this device".

5. Tried installing latest tape drive firmware (CP014615.scexe). This gives the error "Unrecognised Operating System".

6. Installed sg3_utils for SCSI utilities and rescan script. No new devices are detected.


The P212 SAS adapter is listed in /proc/scsi/scsi but not the tape drive. I have tried the old trick of echoing "- - -" to /sys/class/scsi_host/hostN/scan but nothing happens.


Does anyone have one of these rackmount tape drives working with RHEL6? Any input is appreciated.




Frequent Advisor

Re: 1760 SAS Rackmount Not Detected In RHEL6.1

Hello Michael,


Check following:

run the command "dmesg | grep ciss"


this will tell you that the proper driver is loaded for the P212. If all is well, you should see a lines(s) like this:

ciss0: <HP Smart Array P212> port 0xd800-0xd8ff mem 0xfb800000-0xfbbfffff,0xfbdff000-0xfbdfffff irq 24 at device 0.0 on pci6


If you see nothing then you may need to load the CCISS driver (SmartArray Controller) from HP here.





Re: 1760 SAS Rackmount Not Detected In RHEL6.1

Thanks for the reply Eric.


The output of "dmesg | grep cciss" was empty so I installed the kmod from the link you provided. Unfortunately that doesn't seem to have fixed the problem. I tried the scsi-rescan command from sg3_utils and the echo "- - -" trick but still no dice.


It seems odd that searching for drivers on the P212 product page does not provide a link to the RHEL6 x86_64 driver. However, searching for the specific driver returns the link you provided.