StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Can HP AJ042A works alone?

 
Highlighted
Occasional Contributor

Can HP AJ042A works alone?

Hi,all

I recently got an HP tape drive that model is AJ042A, and I want to use it on my Linux server (Ununtu 20.04 LTS). I installed a Qlogic QLE2560 fiber card in my server, and connected AJ042A to the optical interface. So far everything is normal. QLE2560 has recognized my AJ042A in its bios at booting period, and Ubuntu also found the tape drive, there is /dev/st1 in Ubuntu , but if I try to write something with MT command or tar, I got follow error:


/ dev / st1: Cannot write: Input / output error

My other HP DAT72 tape drive is working properly, and I am also familiar with the operation of the tape drive. But I know that AJ042 was originally used for the MSL2024 tape library. I removed the outside part (including power and control cables). Now it has become a 2U full-height LTO drive. I connected 4P power and fiber cable to it. But the two LEDs on its front panel have been blinking at the same time.

I'm not sure what the reason is. I saw a row of jumpers on the rear of the AJ042A which was empty. I think these jumpers are the relationship between the tape drive and the tape library. But I can't find any documents of AJ042A on the HP website. I only found some information about MSL2024, but there is no detailed description about this AJ042A.

So can someone provide me with more information?  any information will be appreciated.

1 REPLY 1
Highlighted
Occasional Contributor

Re: Can HP AJ042A works alone?

I was found the AJ042A tape drive actually works already on my server. When I use 'mt' and 'tapeinfo' command to control it, I got follow result:

$ sudo mt --file=/dev/st1 status
drive type = 114
drive status = 1174405120
sense key error = 0
residue count = 0
file number = 0
block number = 0

------

$ sudo tapeinfo -f /dev/st1
Product Type: Tape Drive
Vendor ID: 'HP '
Product ID: 'Ultrium 4-SCSI '
Revision: 'H6FW'
Attached Changer API: No
SerialNumber: 'XXXA333XXX'
TapeAlert[31]: Hardware B: Tape drive has a problem not read/write related.
TapeAlert[50]: Undefined.
MinBlock: 1
MaxBlock: 16777215
SCSI ID: 0
SCSI LUN: 0
Ready: yes
BufferedMode: yes
Medium Type: Not Loaded
Density Code: 0x46
BlockSize: 0
DataCompEnabled: yes
DataCompCapable: yes
DataDeCompEnabled: yes
CompType: 0x1
DeCompType: 0x1
BOP: yes
Block Position: 0
Partition 0 Remaining Kbytes: 799204
Partition 0 Size in Kbytes: 799204
ActivePartition: 0
EarlyWarningSize: 0
NumPartitions: 0
MaxPartitions: 0

I have tried use clean tape on it, but it still not work. Two led keep blinking orange color at same time. So I have no idea of it. Is my AJ042A damaged?