Showing results for 
Search instead for 
Did you mean: 

Close MailSlot

Go to solution
Occasional Contributor

Close MailSlot

We have one MSL 2024 which is showing close mailslot message and is not responding to any push button commands from the OCP. We tried powering down the drive several times but each time the system completes the startup , it shows unlocking mailslot.. then goes into recovery and finally shows close mailslot message.The mailslot cannot be opened from the front panel. The only button working is the power switch which when pressed power downs the device.

Actions Taken

No 1:
Powered down the device.
Opened the magazine slot manually using a pin from the backside.
Released the mailslot switch and kept the mail slot open and inserted the magazine back in place.
Powered up the device.
Message still appears.

No: 2
Keeping the power on, opened the magazine slot manually.
Closed the mailslot and then inserted the magazine slot.
Message stil appears.

No 3:
With the device powered on, opened the magazine slot manually.
Released the switch and opened the mail slot.
Closed the magazine slot with the mailslot closed.
Device still shows same messsage.

Upgraded the firmware for both the drive and device to the latest version avaialable. Repeated steps No 1 and 2 but no changes.

Any suggestions.

Honored Contributor

Re: Close MailSlot


Log a hardware call, if you haven't already.

I'm not familiar with the MSL2024, but it sounds as though the sensor that detects whether the mailslot is open, has broken.


Honored Contributor

Re: Close MailSlot

I would also suggest to reset the unit to factory default.
You may have the mailslot unconfigured and causing issue.
so record you important config data, reset to default, configure one mail slot again and see if you still have the issue.
Do you have the issue if no mailslot is configured?
anyway if this is not solved with this action, most probably you have a HW issue
Honored Contributor

Re: Close MailSlot

That library uses an optical sensor to check the mailslot position. On the slots in the magazine that can be a mailslot there are two notches in the plastic at the bottom of the slot. One notch is in the middle and should be empty. The other notch is at the side and should contain a little plastic light prism that pipes light in one side and out the other for the optical sensor. If the mailslot is open then the optical sensor goes to the spot that should contain the prism and doesn't find anything. If a prism is missing it looks like the mailslot is open.

If your configuration is incorrect then the library could be looking for a mailslot sensor in a location that is not mailslot capable. Some magazines have all 3 front slots mailslot capable and some only have 1 slot mailslot capable. Another poster already recommended checking those configurations - I agree with that recommendation.

All the non-mailslot locations in the magazine have a prism in the middle of the slot and should only have one notch.
Occasional Contributor

Re: Close MailSlot

I forgot to mention that the mailslot was NEVER configured nor enabled. This issue started happening after i put new tapes in the magazine and tried to do a quick erase using Backup Exec 12.0. The tape got stuck in the drive while the OCP showed Close Mailslot message. Finaly i had to force eject the tape using the OCP commands but the message still remained.

Thank You all for your comments. I will surely try your suggestions and update this thread.