StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

DAT 320 from IBM build by HP Blocksize / Firmware

Occasional Visitor

DAT 320 from IBM build by HP Blocksize / Firmware

We are using DAT 320 USB Tape Drives as backupsystem. We know that this products are EOL.

We bougth some DAT 320 USB Tape Drives labeled by IBM, created by HP. There is one difference to the original HP Drive: the default blocksize. By the original HP Drive the default is 'variable blocksize', the IBM-Device is set to 512 Byte by default. Is there a way to set the default blocksize on the hardware?

We tried HPE Libary and Tape Tools, but there is a password needed for 'Enable Factory Overrides'....

Is there a way to upgrade IBM Tape Drives (created by HP) to the actual firmware VUA8 from HP? The manufactorer of the Tape-Drives is identical.

The IBM-Support doesn´t know of everything......






Re: DAT 320 from IBM build by HP Blocksize / Firmware

Most of the people that worked on that have moved on to other things.  There are a few still around but I'm not sure what I would ask them.

Where are you seeing this information about the default block size?

Whether variable block size or fixed block size is used is determined by the application with a bit in the read/write commands.  There is no drive setting that specifies whether to use variable block mode or fixed block mode.

The BLOCK LENGTH value can be set for both variable length transfers and fixed length transfers. It isn't used primarily in error cases when the host sends reads/writes using variable length mode. The BLOCK LENGTH is frequently set to zero when a host is using variable length transfers. In that case only variable length reads/writes can complete successfully because the drive relies on the application to specify the block length.

Even if the HP drive sets the block length to zero by default and the IBM drive sets the block length to 512 bytes by default there shouldn't be any signficant difference if a well behave application uses variable block mode while writing tapes.

It may be the device driver or an application setting that is choosing the wrong settings.

I work for HPE

Accept or Kudo