StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Data Protector A.05.50 vs Linux clients

 
Highlighted
New Member

Data Protector A.05.50 vs Linux clients

Hello,

I have CM/DP Manager running on a MS Win2k3 server and am trying to import a Linux client, but I keep getting errors like:

# ./omnisetup.sh -server cm-server.backup.local -install da

Import host failed.
System error: Connection timed out

I have checked with nslookup that both the CM and the Linux DA client machine resolves DNS correctly. Both A and PTR records shows correct information and putting the client into drivers/etc/hosts file in CM server doesn't help either.

I have checked that Linux DA client can reach CM server on tcp port 5555 and vice versa.

Telnet from client to server on port 5555 returns:
HP OpenView Storage Data Protector A.05.50: INET, internal build DPWIN_00218, built on 14. august 2006, 07:15

Telnet from server to client on port 5555 returns:
HP OpenView Storage Data Protector A.05.50: INET, internal build 330, built on Tue 12 Oct 2004 11:06:00 PM CEST

Trying to import the client from Data Protector Manager GUI on the CM server also returns error code

Oh btw.. They are on same (backup) network 172.16.150.0/24, not firewalled.

Does anyone have any clue how to make this thing work with Linux clients? It works perfectly with Windows clients.

Best regards,
Ronni
1 REPLY 1
Highlighted
New Member

Re: Data Protector A.05.50 vs Linux clients

*sigh*

I got client import working by adding the client's hostname (Not just the FQDN of the client, but the local hostname "client.sl.local") to CM server's hosts file and removing the cell_server file from client system.

Now, when looking in Data Protector Manager I can see that Disk Agent A.05.50 is installed and the client platform is "gpl i686 linux-2.6.9-55.ELsmp" which is all fine.

However, if I right-click the client and select "Check Installation.." I hit a wall again:


Starting installation session on 2. september 2008, 04:52:39...

Getting list of clients for installation...

Connecting to client client.sl.local...

Checking for response from system client.sl.local.

Client client.sl.local : client not responding.

Error connecting to client client.sl.local
Skipping client!

Installation session finished on 2. september 2008, 04:57:43.


============================================================================
Session aborted!
============================================================================

Any idea what's wrong now? Still, no firewall between CM server and client and "netstat -ltnp" on the client returns:

tcp 0 0 0.0.0.0:5555 0.0.0.0:* LISTEN 31820/xinetd
tcp 0 0 0.0.0.0:23 0.0.0.0:* LISTEN 31820/xinetd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2750/sendmail: acce
tcp 0 0 :::22 :::* LISTEN 2692/sshd