StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Driver issue with Ultrium 448 SAS

 
SOLVED
Go to solution
Highlighted
Advisor

Driver issue with Ultrium 448 SAS

I've got an ultrium 448 sas (p/n DW085A), connected to a dl380 G5 server. The hba is a SAS card SC44GE (p/n 416096-B21).
It always worked fine, until I realise it wasn't doing hardware compression using ntbackup. Tapes are 200gb with /hc:off and 400gb with /hc:on. When the volume grew over 200gb, it just wouldn't do the backup.
In order to solve this issue I tried to install a microsoft hotfix that would supposedly repair that issue. I got it from support.microsoft.com - it was the article kb 827475. When trying to run it I got a message saying that there was a windows update already installed, which was more up-to-date than this particular hotfix, so the installation was aborted.
Then, I had the magnificent idea of checking www.windowsupdate.com. There was only one update left, it was precisely a hardware update for the Ultrium 448 SAS. I committed the biggest mistake of my life when I decided to install this driver, since from that day on it was impossible for me to run another backup again. I've tried on multiple tapes, with multiple volumes, but there's always a "hardware failure" in the error report of ntbackup, and backup is aborted very soon after it started.
Since that day, nov. 24, i've tried almost everything, but it still won't work.
The event viewer reported errors, all related to the lsi_sas controller, but I'd never touched those drivers and it used to work ok. I just committed the crime of trusting a driver update for the ultrium (not the hba) from microsoft official website. I promise I'll never do it again.
I've updated the drivers for both the tape drive and the hba, with the latest version from hp website. I also tried to update the firmware for the hba, but I got an error saying that the software was for a "machine type" other than the current machine. I've got W2003 server x64. In the website, there's a version for each of the operating systems (W2003 32bit, and W2003 64bit), but although they're labelled differently the files are identical, and I get the same error with either of them. So I didn't manage to update the firmware.
In desperation, I tried older driver versions for both the tape drive and the hba, but it wouldn't work either. I just got a wide variety of errors -from removable storage service (NtmsSvc) hanging at Stopping status, to all sorts of system errors in the event viewer with source "lsi_sas". It never worked again. I got back to the latest versions.

Current situation is:
When I execute the backup, it starts ok, no problems with ntbackup.exe, rsm.exe or removable storage service. After a few minutes the backup is always aborted. Sometimes it lasts 5 minutes, and sometimes 30, but eventually it ALWAYS fails. I've got to do a 3 hour long backup, and I'd never had a problem with it until I installed that f****** windows update. Rolling back to the previous drivers didn't work either.
The second it fails I get the following error:
Event Type: Error
Event Source: Lsi_sas
Event Category: None
Event ID: 11
Date: 12/9/2008
Time: 2:28:59 PM
User: N/A
Computer: OPERA-WEB
Description:
The driver detected a controller error on \Device\RaidPort1.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 0010000f 00680001 00000000 c004000b
0010: 31140000 00000000 00000000 00000000
0020: 00000000 00000000 00000000 00000000
0030: 00000000 c004000b

Immedaitelly after that, I get other errors, saying that the device is not ready for access, or that the device Ultrium bla bla disappeared from the system without first being prepared for removal.

ANY HELP WILL BE GREATLY APPRECIATED.
THANKS A LOT FOR YOUR TIME.
Lenny
20 REPLIES 20
Highlighted
Honored Contributor
Solution

Re: Driver issue with Ultrium 448 SAS

Can you install L&TT and perform some test backups with that drive?

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=406729&prodNameId=406731&swEnvOID=1060&swLang=13&mode=2&taskId=135&swItem=co-66503-1

The messages about controller error and device dissapearing from the system do not look good.
Highlighted
Advisor

Re: Driver issue with Ultrium 448 SAS

I've performed an "LTO Drive Assessment test" and it turned out well. But it only lasted for 15 minutes, and the backup usually fails after that time.

|__ Analysis Results
|__ LTO Drive Assessment Test, version V19.08.2008
|__ Test run: Fri Dec 12 17:06:18 2008
|__ Data Cartridge Information:
|__ Vendor: HP
|__ Format: LTO-2
|__ ANALYSIS OF HISTORICAL INFORMATION (from drive logs):
|__ version: V18.11.2008
|__ Firmware rev T61D is up-to-date for Ultrium 2-SCSI as of Tue Feb 27 19:00:00 2007.
|__ There were 18 rules checked.
|__ Device Analysis has checked the historical information and no problems were found.
|__ RESULTS OF TESTS ON THIS DRIVE
|__ [Please note: the operations performed by this overwrite test will NOT be
|__ reflected in the Support Ticket usage/health information.]
|__ Amount of data requiredâ test option : Default
|__ Iteration number: 1 of 1
|__ Overall Margin: Great margin (12.5 GB written)
|__ The LTO Drive Assessment Test has checked the history and/or operation of the selected drive, and
|__ The test has PASSED and the drive is GOOD.
Highlighted
Regular Advisor

Re: Driver issue with Ultrium 448 SAS

You can run read/write test, then from option button you can set up the amount of data to write.

Highlighted
Advisor

Re: Driver issue with Ultrium 448 SAS

Ok. I did the read/write test. In the amount of data parameter I chose "whole tape".
20 minutes after the test started I got the same errors on the event viewer:

Event Type: Error
Event Source: Lsi_sas
Event Category: None
Event ID: 11
Date: 12/12/2008
Time: 11:50:06 PM
User: N/A
Computer: OPERA-WEB
Description:
The driver detected a controller error on \Device\RaidPort1.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 0010000f 00680001 00000000 c004000b
0010: 31140000 00000000 00000000 00000000
0020: 00000000 00000000 00000000 00000000
0030: 00000000 c004000b

Event Type: Error
Event Source: PlugPlayManager
Event Category: None
Event ID: 12
Date: 12/12/2008
Time: 11:50:06 PM
User: N/A
Computer: OPERA-WEB
Description:
The device 'Hewlett Packard LTO Ultrium-2 drive' (SCSI\Sequential&Ven_HP&Prod_Ultrium_2-SCSI&Rev_T61D\5&7dce622&0&000500) disappeared from the system without first being prepared for removal.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00000000

Event Type: Error
Event Source: Storage Agents
Event Category: Events
Event ID: 1223
Date: 12/12/2008
Time: 11:50:14 PM
User: N/A
Computer: OPERA-WEB
Description:
SAS Tape Drive Status Change. The tape drive in Slot 1, Device 5 with serial number "HU12847N9K", has a new status of 3.
(Tape Drive status values: 1=other, 2=ok, 3=offline)
[SNMP TRAP: 5025 in CPQSCSI.MIB]
Data:
0000: 01c0009a 00000003 00000005 03010304
0010: 746f6c53 00003120 00000000 00000000
0020: 00000000 00000000 00000000 00000000
0030: 00000000 00000000 00000000 00000000
0040: 00000000 00000000 00000000 00000000
0050: 00000000 00000000 00000000 00000000
0060: 00000000 00000000 00000000 00000000
0070: 00000000 00000000 00000000 00000000
0080: 00000000 00000000 00000000 00000000
0090: 69766544 35206563 00000000 00000000
00a0: 00000000 00000000 00000000 00000000
00b0: 00000000 00000000 00000000 00000000
00c0: 00000000 00000000 00000000 00000000
00d0: 00000000 00000000 00000000 00000000
00e0: 20504800 52544c55 344d5549 44203834
00f0: 00005652 00000000 00000000 00000000
0100: 00000000 00000000 00000000 00000000
0110: 00000000 00000000 00000000 00000000
0120: 00000000 00000000 00000000 00000000
0130: 00000000 00000000 00000000 00000000
0140: 00000000 00000000 00000000 00000000
0150: 00000000 00000000 00000000 00000000
0160: 36540000 00004431 48000000 38303155
0170: 394e3730 0000004b 00000000 00000000
0180: 00000000 00000000 00000000 00000000
0190: 00000000 00000000 00000000 00000000
01a0: 00000000 00000000 00000000 31303035
01b0: 30413031 43303130 34363138 00000000
01c0: 00000000 00000000 00000000 00000000
01d0: 00000003 00000005 00000000 00000000
01e0: 843504c7 0001000f 00000001 000000ff
01f0: 00321600 00000000 009a01c0 ffff000a
0200: 0000ffff 00000000 000c0000 0167008c
0210: 8080000b 80418051 00010001 00000002
0220: 00000004 00040000 00000004 00000000
0230: 00000000 00000000 00000000 00000000
0240: 00000001 00000000 0026cf80 00000000
0250: 00000008 00000000

Event Type: Information
Event Source: Storage Agents
Event Category: Events
Event ID: 1223
Date: 12/12/2008
Time: 11:52:14 PM
User: N/A
Computer: OPERA-WEB
Description:
SAS Tape Drive Status Change. The tape drive in Slot 1, Device 5 with serial number "HU12847N9K", has a new status of 2.
(Tape Drive status values: 1=other, 2=ok, 3=offline)
[SNMP TRAP: 5025 in CPQSCSI.MIB]
Data:
0000: 01c0009a 00000003 00000005 02020202
0010: 746f6c53 00003120 00000000 00000000
0020: 00000000 00000000 00000000 00000000
0030: 00000000 00000000 00000000 00000000
0040: 00000000 00000000 00000000 00000000
0050: 00000000 00000000 00000000 00000000
0060: 00000000 00000000 00000000 00000000
0070: 00000000 00000000 00000000 00000000
0080: 00000000 00000000 00000000 00000000
0090: 69766544 35206563 00000000 00000000
00a0: 00000000 00000000 00000000 00000000
00b0: 00000000 00000000 00000000 00000000
00c0: 00000000 00000000 00000000 00000000
00d0: 00000000 00000000 00000000 00000000
00e0: 20504800 52544c55 344d5549 44203834
00f0: 00005652 00000000 00000000 00000000
0100: 00000000 00000000 00000000 00000000
0110: 00000000 00000000 00000000 00000000
0120: 00000000 00000000 00000000 00000000
0130: 00000000 00000000 00000000 00000000
0140: 00000000 00000000 00000000 00000000
0150: 00000000 00000000 00000000 00000000
0160: 36540000 00004431 48000000 38303155
0170: 394e3730 0000004b 00000000 00000000
0180: 00000000 00000000 00000000 00000000
0190: 00000000 00000000 00000000 00000000
01a0: 00000000 00000000 00000000 31303035
01b0: 30413031 43303130 34363138 00000000
01c0: 00000000 00010000 00000000 00000000
01d0: 00000003 00000005 00000000 00000000
01e0: 843504c7 0001000f 00000001 000000ff
01f0: 00321600 00000000 009a01c0 ffff000a
0200: 0000ffff 00000000 000c0000 0167008c
0210: 8080000b 80418051 00010001 00000002
0220: 00000004 00040000 00000004 00000000
0230: 00000000 00000000 00000000 00000000
0240: 00000001 00000000 0026cf80 00000000
0250: 00000008 00000000

The test hasn't finished yet. Apparently, these errors haven't prevented the test from running. As the last event shows, two minutes after the error, the tape went back to normal status. When the test finishes, I'll post the results.

Thanks a lot for your help, to both of you!
Highlighted
Advisor

Re: Driver issue with Ultrium 448 SAS

It is clear now that the test won't finished. It froze at the 50th GB.
Though it continued for some time after the errors in the event viewer that I copied in the previous post. The test hung and there were no more errors in the event viewer when it did. I think that's quite funny.
Here is the test result:
Test 'Read/Write Test' started on device 'HP Ultrium 2-SCSI' at address '3/0.5.0'
|__ Performing Device Self Test
|__ Performing 1st write phase of read/write test
|__ Writing 1 GB
|__ Writing 2 GB
|__ Writing 3 GB
|__ Writing 4 GB
|__ Writing 5 GB
|__ Writing 6 GB
|__ Writing 7 GB
|__ Writing 8 GB
|__ Writing 9 GB
|__ Writing 10 GB
|__ Writing 11 GB
|__ Writing 12 GB
|__ Writing 13 GB
|__ Writing 14 GB
|__ Writing 15 GB
|__ Writing 16 GB
|__ Writing 17 GB
|__ Writing 18 GB
|__ Writing 19 GB
|__ Writing 20 GB
|__ Writing 21 GB
|__ Writing 22 GB
|__ Writing 23 GB
|__ Writing 24 GB
|__ Writing 25 GB
|__ Writing 26 GB
|__ Writing 27 GB
|__ Writing 28 GB
|__ Writing 29 GB
|__ Writing 30 GB
|__ Writing 31 GB
|__ Writing 32 GB
|__ Writing 33 GB
|__ Writing 34 GB
|__ Writing 35 GB
|__ Writing 36 GB
|__ Writing 37 GB
|__ Writing 38 GB
|__ Writing 39 GB
|__ Writing 40 GB
|__ Writing 41 GB
|__ Writing 42 GB
|__ Writing 43 GB
|__ Writing 44 GB
|__ Writing 45 GB
|__ Writing 46 GB
|__ Writing 47 GB
|__ Writing 48 GB
|__ Writing 49 GB
|__ Writing 50 GB
|__ The test function encountered an unrecoverable error condition, the test failed.
|__ Internal error (OC_Dlg_PureMFC_Test.cpp, 2480, Caught non-L&TT exception)
Highlighted
Advisor

Re: Driver issue with Ultrium 448 SAS

What can I do next?
Thanks.
Lenny
Highlighted
Advisor

Re: Driver issue with Ultrium 448 SAS

Any ideas?
Anything might be helpful.
Thanks.
Highlighted
Regular Advisor

Re: Driver issue with Ultrium 448 SAS

Can you upload the support ticket?

Just open L&TT, select the drive. Then click support button, extract device data and save support ticket to file.

You don't need to run any test. This way the software will get the logs saved in the drive.
Highlighted
Advisor

Re: Driver issue with Ultrium 448 SAS

I attach the report.
Thanks