StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

ESL 712E configuration on Solaris 8 via SAN

Go to solution
Occasional Advisor

ESL 712E configuration on Solaris 8 via SAN


We are trying to configure zoned tape drives from ESL 712E on Solaris 8 via SAN.

We have completed the following steps
1. Zoned the Tape drives for the server's HBA card.
2. Installed the HBA drivers (QLogic) on the Solaris.
3. Installed the HP DP Disk agent, and Media agent softwares

However we are not able to see the Tape drives configured on /dev/rmt directory of the server.
Using the QLogic supplied SAN surfer CLI, we are able to see some devices, but cannot see what type of device they are
Following is the output I am getting
HBA 0 (OS 0): QLA2300/2310 Port 1 WWPN: 21-00-00-E0-8B-1D-72-F6 Port ID: 0B-0D-00
Path : 0

Device ID : 0x0a
Product Vendor : HP
Product ID : NS E2400FC
Product Revision : 5928
Serial Number : 5928
Node Name : 10-00-00-E0-02-02-D0-A9
Port Name : 10-00-00-E0-02-42-D0-A9
Port ID : 01-17-00
Product Type : Device
Number of LUN(s) : 0
OS Target Name :
Status : Online

We have asked our SAN admin to check the zoning and found that the server has similar zoning as another SUN server in which this is working.

We asked the backup admin to see if he could add the server to TL's ACL, he could not find the server's WW when tried to scan the new devices.

Please let me know if we are missing some steps.
Trusted Contributor

Re: ESL 712E configuration on Solaris 8 via SAN

Nothing the ESL has some major bugs according to me.

Just reboot the ESL and let me know if that worked.

If you think you have done everything right to get the tape drives visible then go ahead and reboot the ESL. If you still dont find the drives, then I think you can just copy the st.conf from the Solaris 8 server which seems to work for you.
Honored Contributor

Re: ESL 712E configuration on Solaris 8 via SAN

Have you configured "Secure Manager" on your ESL to present the drives to the server? The ESL will not present the drives to any servers until you have configured it to allow access to those servers. That prevents a lot of problems when zoning isn't set up correctly and servers that aren't tape safe are in the same zone.
Trusted Contributor

Re: ESL 712E configuration on Solaris 8 via SAN


Ur suggestion is right, but he does not find the WWPN of the server in the secure manager.

We faced the same issue as suresh, inspite of the latest microcode in place.

But it seems like Suresh is not reading the replies.

Suresh : Did u resolve the problem???
Occasional Advisor

Re: ESL 712E configuration on Solaris 8 via SAN

Hi Biju / Curtis,

Sorry for not replying before.

We have not yet rebooted the ESL712e. I am waiting for the Backup admin to perform this. We did try adding this server to the secure manager, but the Tape library does not show this server or its WWN in its list of newly zoned servers.

Thanks for the inputs.

Trusted Contributor

Re: ESL 712E configuration on Solaris 8 via SAN

Thanks for the reply,

I'm very sure that you would need a reboot. Do a full power re-cycle if possible.

After the reboot check

1. whether you find the host WWPN's in secure manager.

2. Give these hosts access to some drives and robots. If you dont see the drives then u will need another reboot. I know HP guys will not agree, but I have worked on ESL 712E and the solution center has never given me a solution to this. The new libraries are better with a FC backend, but ESL is'nt that robust.

Gimme some points if the solution (yeah what if its a reboot), I need to open my account.