StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

HP Ultrium 3000 Not Showing in Device Manager

Occasional Advisor

HP Ultrium 3000 Not Showing in Device Manager

My HP Ultrium 3000 external tape drive is not being detected by the computer at all. I've tried everything I could find with regard to installing drivers, checking compatibility, etc, but to no avail.

* The tape drive powers up correctly, and the status LED stabilises into ready state
* The SAS controller shows up in Device Manager, but the tape drive does not
* HPE Library and Tape Tools Version 4.22 does not detect the tape drive, only the controller
* LTFS Configurator also fails to detect the tape drive

Tape drive:
* Hardware: HP LTO-5 Ultrium 3000, Model Number EH958B
* Driver Download Title: HPE StoreEver Tape Drivers for Windows (American, International),, 24 Oct 2016
* Relevant Driver: HP LTO Tape Drive

SAS controller:
* Hardware: LSI SAS 9201-16e 6Gb/s Host Bus Adapter
* More information:
* Relevant driver: Preinstalled for Windows 10, and also have tried the website driver download

SAS cable:
* Hardware: External SAS 6Gb/s cable
* Have tried the cable in all four external SAS ports on the controller card

Operating system:
* Windows 10 Pro, 64-bit

The computer is a standard workstation style machine.

I appreciate any advice you can provide - many thanks in advance for your help in resolving this issue.

Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

P.S. The cable is marked  with "430066-001", which seems to show as compatible on PartSurfer:

"430066-001 SAS Cable - External mini SAS (SFF8088) to mini SAS (SFF8088) - Connects to HP StorageWorks 1U SAS rack-mount kit - 2m (6.56ft) long"


The SAS controller is LSI rather than an HP model, but as far as I can see this shouldn't be a show-stopper?

Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

I did find this page:

It indicates that (despite all the other compatibility guidance), when not using the drive with an HP server but with a third party workstation, the following controller/HBA is recommended:

"For 3rd Party servers and workstations
64-bit 133-MHz Single Channel Ultra320 SCSI G2 Host Bus Adapter (HBA)     374654-B21
This SCSI controller supports a wide range of connectivity to non-HP 32-bit servers."

More info on that card can be found here:

However that controller is actually not listed on PartSurfer as far as I can see:

In the November 2016 v3 version of the HP Data Compatibility Matrix doc, there's no mention of it either. And actually:

The "Hewlett Packard Enterprise - StoreEver Standalone Tape Controllers and SAS Cables // Workstation Only Controllers" lists only LSI cards.

So I'm really at a loss. I can buy one of those cards too in the hope that it makes a compatibility difference, but I have no real reason to believe it will help. Ideas?

Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

In the absence of any replies here so far, I've ordered the following:

* HP P212 Smart Array PCI-E SAS SATA RAID
* HP Smart Array P410 P212 P411 256MB Write Cache Module

In the hope that this might be a compatibility problem. I'll post the results obviously when I've been able to re-test. However in the meantime I'd still really appreciate any thoughts / guidance on what the problem could be.

Many thanks, Rob.


Re: HP Ultrium 3000 Not Showing in Device Manager

I just read through your posting.  It is an interesting case.

SAS HBA support for tape drives is primarily determined by whether the controller supports all of the SAS protocol retry mechanisms.  Some SAS controllers don't and cause errors to be reported when the issue was one that should have been able to be recovered without error.  It is really rare for a controller to not detect/report the tape drive. A few array controllers block out devices that report as tape but I have only seen that with array controllers.

I haven't seen any examples of the Broadcom/Avago/LSI controller you mentioned in your first posting but I would expect that it should work.  Controllers in the LSISAS family usually have full SAS protocol support and work fine with tape even if they haven't gone through formal testing at HPE.

The HPE P212 with cache module card that you list in your later message definitely should work with your tape drive and has been tested with a lot of different HPE tape drives but it is an older controller that isn't tested very often anymore.

The cable you list should also be fine.

If there are any SAS BIOS utilities in your LSI controller it would be interesting to see if the controller BIOS is able to detect the tape drive. Otherwise I don't have a lot of suggestions I can offer at this point.

I work for HPE

Accept or Kudo

Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

Thanks very much for the response Curtis. Really appreciate your thoughts.

I've looked hard for any kind of BIOS or configuration utility, but they seem to only be available for the integrated LSI controllers, not for PCIe cards. I did actually try SAS2IRCU, but it doesn't detect the controller, since I guess it's only interested in the dedicated RAID controller machines. Similarly, all the BIOS options / utilities are for the same kind of setup.

I get the same error message described at as meaning no controllers are present.

> sas2ircu.exe list
LSI Corporation SAS2 IR Configuration Utility.
Version (2014.09.18)
Copyright (c) 2008-2014 LSI Corporation. All rights reserved.

SAS2IRCU: MPTLib2 Error 1

I'll wait for the HPE P212 to arrive and then see what that yields.

Thanks again, Rob.

New Member

Re: HP Ultrium 3000 Not Showing in Device Manager

Were you able to solve this issue?  I have the same LSI card and LTO 5 drive with the same issue.  Sas controller shows up in device manager windows 10, but no LTO drive recognized in windows.  It is recognized in the LSI POST screen.