StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Surestore 230 problem

 
Highlighted

Surestore 230 problem

Hi guys. I have obtained this refurbished LTO-1 drive with the fornt panel identifying it as "hp surestore ultrium 230" and a p/n or serial "c7369-60040-zk". I am using windows XP here.

The problem I have with this drive is that it partially works. Sometimes I will be able to fill a whole tape and verify it, and other times either:
(1) the write will stop after the first 15-20mb, the light will stay on (not blinking) and the tape is forwarded without any errors in the windows event log, or
(2) the controller will produce an ID9 event (did not respond within the timeout period) followed by an ID15 event on hplto (tape is not ready for access yet). Sometimes the drive's led will shut off, in which case the device disappears from the system.

Now, I have two controllers here both 29160, one Compaq branded (pulled from some proliant I think, displaying HP stuff when it boots up), and another Adaptec branded.

I also have two cables here (U160 & U320 LVD), terminated, and a scsi disk. The disk has been working flawlessly wit the compaq controller (and now with the adaptec); no errors at all. I have also used two tape brands, Dell and IBM -- same results for both.

I did a health test. The drive appears too hot in the ticket but that is because I had the case open when I obtained the ticket. The connectivity test passes as well (tried a couple of iterations).

Now, the drive assessment test does fail after the erase part with a read error. But since i've seen the drive working at times at both read/write modes, I'm speculating at what might be wrong.

I've also read that it might be a firmware problem. HP does not provide a firmware for this device (wrong personality against StorageWorks 230 firmwares). I googled for it and it sounds like a powervault 100t LTO drive, but wrong personality again.

Any suggestions? I'm not sure how to proceed with this drive. I am especially puzzled with the sporadic successful operation.

Kind regards,
Christos
5 REPLIES 5
Highlighted

Re: Surestore 230 problem

With the case now closed, and LTT reporting temperature being OK, I moved the drive to the compaq controller (ASYNC mode). See ticket in attachment.

I started xTalk to do some tests:

Display_Drive_Information
____________________________________________________________

Drive Information Report
Drive Serial Number ------- : IE72E03555
Device Type --------------- : Tape
ANSI Version -------------- : SPC
Media Changer Present ----- : No
SftRe --------------------- : No
Tagged Command Queuing ---- : No
Linked Commands Support --- : No
Synchronous Data Transfers : Yes
16-bit Data Transfer ------ : Yes
32-bit Data Transfer ------ : No
Relative Addressing ------- : No
Vendor ID ---------------- : HP
Product ID ---------------- : Ultrium 1-SCSI
Product Revision Level ---- : E15V
Product Family ------------ : Not Specified
Brick Revision ------------ : ware
Servo FW Revision --------- : 436F6D70h
Servo FW Checksum --------- : 6F6E656Eh
Servo EEPROM Checksum ----- : 74203D20h
Controller FW Checksum ---- : 4669726Dh
Controller FW Build Date -- : ware Version = 004.
Power On Hours ------------ : 0
Tape Motion Hours --------- : 0
# of Tape Loads ----------- : 0
MB Written ---------------- : 0
MB Read ------------------- : 0

However, the interconnect test fails (it also previously failed for the adaptec controller):

SCSI Interconnect Test
Write/Read Pass @ 10 of 100
Write/Read Pass @ 20 of 100
Write/Read Pass @ 30 of 100
Write/Read Pass @ 40 of 100
Write/Read Pass @ 50 of 100
Write/Read Pass @ 60 of 100
Sense: CC: CC ASC: CC ASCQ: CC = "No Sense Available for this condition"
VS Sense: 0
Catagory: N/A
Details: No error
Data Comparison Problem Detected
There may be an issue with * The SCSI Bus Terminator * The SCSI Cable * The HBA or Drive
Please check your system for these issues and rerun the Device Health Check Test.
Problem Detected

Testing immediately after connectivity from LTT, freezes LTT (does not show failure). The event log does not show anything funny about the controller/drive.
Highlighted

Re: Surestore 230 problem

I must also add that I have tried other things as well:
(1) minimise power consumption
(2) disabled integrated peripherals (including all sata/raid controllers)
(3) fresh XP install, no antivirus present
Highlighted
Frequent Advisor

Re: Surestore 230 problem

Hi Christos,

The current firmware file is ftp://ftp.hp.com/pub/information_storage/software/ltt/firmware/LTT_Ultrium_1-SCSI_E31R_HPlib.frm

LTT should be able to update the drive with it. The drive temperatures are sporadic and not sure why this is happening. There are overheated warnings and below minimum warnings. Please ensure the airflow is properâ ¦

I have noticed the drive assessment test has failed on two occasions. I would suggest running the test again after updating the drive firmware revisions and with a known good media.

If the test fails, would suggest contacting HP Technical Support for assistance.

Regards,
Satya
LTT Team
Highlighted

Re: Surestore 230 problem

Hi there. Much earlier to your message I updated the firmware to E32V/OEM8, but it didn't change anything (I have attached a ticket).

The firmware you suggest is not acceptable by LTT (wrong personality). Could this be because I flashed to that one?

Thanks for the help. Christos.

ps the airflow is OK now.
Highlighted

Re: Surestore 230 problem

> Hi there. Much earlier to your message I updated the firmware to
> E32V/OEM8, but it didn't change anything (I have attached a ticket).

Sorry, I actually meant E32U/OEM8.