StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Surestore and Storageworks Autoloader 1/8

Regular Advisor

Surestore and Storageworks Autoloader 1/8

I have 3 Surestore and 1 Storageworks Autoloader 1/8 units. I have 1 Dell Powervault 122T. Until yesterday I had two of the Surestore (C9264CB) units attached to my Proliant 6500's onboard SCSI channel. One of the units had a Benchmark VS640 tape drive, the other a VS80. The VS640 ate a tape a few weeks ago. I removed the pieces of the tape, blue out what ever I could see, ran the cleaning cartridge and put it back in service. It lasted approximately a week when it broke the tape leader. I replace the leader, tested it for an hour then put it back in service. The first time I tried backing up to tape it broke another leader. I replace the leader again, it backed up three times then started acting real weird. It thought it had a cleaning cartridge and displayed cleaning drive on the LCD but it had a data cartridge. It then ripped apart another leader. I replaced it and started a backup, it ran for 20 minutes then sat there saying writing but no movement of tape, the unit then reset and started the cleaning drive nonsense again with a data tape. After restarting the tape drives and linux server I started a backup. It appeared to be working but it actually pulled all the tape out of the cartridge filling the take-up reel. I have given up on that unit and took it off the SCSI chain. I took my other units and have four daisy chained on the Linux server's internal SCSI adapter. The server identified each correctly when I booted and they are defined as /dev/sg0 .. /dev/sg3 but I can only interact with /dev/sg2 using the mtx tool. I installed the HP_LTT and it sees all the devices and will interact with the VS80 units, the VS640 it says are unsupported. I ran tests with the sg0 and sg3 deivces and the tests succeeded but I can not figure out how to interact via shell scripts with a command like mtx -f /dev/sg0 load 1. The command mtx -f /dev/sg0 inventory works but no load or unload commands work. I've tried here before and people suggested LUN support but the Proliant 6500 onboard SCSI doesn't appear to support LUN (I'm probably wrong).

When I have the sg0, sg1 and sg3 devices connected to a Proliant DL380 attached to an Adaptec SCSI card (with LUN support turned on) these drives are addressable using MTX.

How is it possible that the HP_LTT can interact but MTX can not? The HP_LTT is a binary file so I can't see how it is interacting.

1 HP C9264CB-VS80 (Address: 10.1.0[1-/dev/sg0])
2 BNCHMARK VS640 (Address: 10.2.0[1-/dev/sg1])
3 HP C9264CB-VS80 (Address: 10.4.0[1-/dev/sg2])
4 HP C9264CB-VS80 (Address: 10.5.0[1-/dev/sg3])

Other Devices: