StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Ultrium 1760 SAS on Ubuntu 10.10 server

Occasional Contributor

Ultrium 1760 SAS on Ubuntu 10.10 server


I have a Ultrium 1760 SAS on an HP Proliant 150ML G6. It is connected to an HP P410 SAS card.

Ubuntu detects it, after doing a

echo "engage scsci" > /proc/driver/cciss/cciss1

I can backup:

tar czvf /dev/st0 /home

But when I try to extract or do a compare,

tar -dlpzvf /dev/st0 /home
tar (child): /dev/st0 : Cannnot read: Input/Output error

dmesg shows

st0 : Error 6 (driver bt 0x0, host bt 0x0)

I have used hp library and tape tools v 4.11 and
tried the device performance test without error.

What could be wrong?
Occasional Contributor

Re: Ultrium 1760 SAS on Ubuntu 10.10 server

I've tried both dd commands, as explained in this thread, and they don't generate the same behaviour.

On the hardware side, my SAS card is an P410 512M (plain, no BBW or anything). The cable, which came with the tape drive, one end is connected to the card, the other end is splitted and has two connectors, one for the tape (used), the other for the drive cage (not used).

I've done some tests with the HP LTT tool, and as far as I can tell, they seems correct:

Found Device: Found 'HP Ultrium 4-SCSI' at address 40.0.0[4-/dev/sg2]

-Drive Info:
Product ID : Ultrium 4-SCSI
Drive Technology : LTO
Mech. Serial Number : HU1033BTYM
Firmware Rev : U52D/Standalone
Target ID : 0
Target LUN : 0
OBDR Capability : Supported
WORM Capability : Supported

Cartridge Information (for cartridge currently in drive):
Cartridge Type : LTO 4 Data
* Capacity : 1600 GB (2:1 data compression)
Write Protected : No
Barcode : Not Set
Cartridge Partitioned: No

- Device Perf Test
Started on Drive (Ultrium 4-SCSI)
- Opening Tape Drive 40.0.0[4-/dev/sg2]
- Successfully opened the Tape Drive /dev/nst0
- Spinning Up
- 2.1 GB written in 13.0 seconds at 166 MB/s (Min 0 MB/s, Max 9 MB/s)

I'll give cpio a try.