StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Ultrium920 (SCSI, ext) and SC11XE won't pass Domain Validation (Gentoo Linux)

 
Highlighted
New Member

Ultrium920 (SCSI, ext) and SC11XE won't pass Domain Validation (Gentoo Linux)

Overview
========

The problem is that I cannot get Ultrium920 tape drive to work with SC11XE card.

I've tried numerous kernel-compile options (2.6.25), but I cannot get Domain Validation to succeed when a tape is in this drive! In fact, I have two identical new servers, each with an HP SC11XE card, and each with an external SCSI '920 tape-drive. All tests are identical on each, so I don't think I have any damaged hardware at all.


Observations
============

Seems perhaps the Tape-Writeable test locks it up? The driver-in-use is "mptspi", and lspci shows:

04:08.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev c1)
Subsystem: Hewlett-Packard Company Unknown device 322a
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- SERR- Latency: 72 (4000ns min, 1500ns max), Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 16
Region 0: I/O ports at ce00
Region 1: Memory at efde0000 (64-bit, non-prefetchable)
Region 3: Memory at efdc0000 (64-bit, non-prefetchable)
Expansion ROM at efc00000
Capabilities: Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000 Data: 0000
Capabilities: PCI-X non-bridge device
Command: DPERE- ERO- RBC=512 OST=8
Status: Dev=04:08.0 64bit+ 133MHz+ SCD- USC- DC=simple DMMRBC=2048 DMOST=8 DMCRS=16 RSCEM- 266MHz- 533MHz-
Kernel driver in use: mptspi


With a tape in the tape-drive, right at the "Beginning Domain Validation" echo, I get a hard-lockup (unresponsive to any kybd, no SSH, no serial-console-output).

Without a tape, the server boots OK, with these log-messages:

mptbase: ioc0: Initiating bringup
ioc0: LSI53C1020A A1: Capabilities={Initiator,Target}
scsi10 : ioc0: LSI53C1020A A1, FwRev=01032700h, Ports=1, MaxQ=255, IRQ=16
scsi 10:0:3:0: Sequential-Access HP Ultrium 3-SCSI D22D PQ: 0 ANSI: 3
target10:0:3: Beginning Domain Validation
target10:0:3: Domain Validation skipping write tests
target10:0:3: Ending Domain Validation
target10:0:3: FAST-160 WIDE SCSI 320.0 MB/s DT IU RTI PCOMP (6.25 ns, offset 64)
st 10:0:3:0: Attached scsi tape st0
st 10:0:3:0: st0: try direct i/o: yes (alignment 4 B)
st 10:0:3:0: Attached scsi generic sg2 type 1

After successful no-tape bootup, inserting a tape and trying any "mt" command will again produce immediate, hard-lockup :-(

Other Tests
===========

1) Connecting an Ultrium230e LTO1 tape-unit shows completely normal operation of the SC11XE and motherboard (albeit at 80MB/s). Tape-in boot, tape-out boot, tape-later-inserted and "mt" commands all work as they should.

2) Test-installing Windows 2003 Server, combined with all updates and HP drivers did allow SC11XE + '920 to communicate - all diagnostics passed, and firmware is up-to-date.


Can anyone suggest some way forward on this?

TIA!
1 REPLY 1
Highlighted

Re: Ultrium920 (SCSI, ext) and SC11XE won't pass Domain Validation (Gentoo Linux)

Replace the SC11XE with a PCI-X based SCSI card. The traditional 374654-B21 will work, but you also won't go wrong with a tried and trusted Adaptec card.

I'm willing to wager a fair amount of money that the Windows deployment you tried doesn't work properly either - if you search these forums, you'll find numerous people with an SC11xe/Ultrium920 combo who ran into issues on Windows where backups would fail after a few GB due to too many write errors.

I work for an HP reseller/integrator, and we've seen this problem time and again (although on our case we've always worked on a Windows platform.) Save yourself the trouble and just get a different card.