StoreVirtual Storage
Showing results for 
Search instead for 
Did you mean: 

P4000 application managed snashot SAN I/Q 9.5

Frequent Advisor

P4000 application managed snashot SAN I/Q 9.5



I red several documents about implementing application aware snapshots with vcenter 5.

Now i red the following documents:

1. ApplicationAwareSnapshotManagerDeploymentGuide

2. HP SAN User guide


As stated in the documentation (it's kinda unclear) the following needs to be applied.


In my case the CMC server is also VC so no routing issues.



1. Configured ISCSI on CMC/VC server. I added the VMFS to READ for the VC. (don't want to destroy my VMFS volumes)

I added a second NIC for ISCSI. I can  ping the the VC on both LAN and ISCSI network. So no routing issues.

2. Added the VC to serverlist in CMC and put the connection ip server (LAN ip and ISCSI tried)of the VC.

3. Installed the HP application manager (Default port)

4. Configured authentication (succesfull test)


when i try a app integrated snapshot i immediatly get : failed to create snapshot. Point in time works fine.



Now what i tried:

1. changed port

2. Add the ip address with port in the CMC so

3. Checked if my windows 2008 r2 "sees" the LUNS in the storage management.


I red all the documenation but it's kinda unclear what i'm missing here.


anyone got a idea?




Still error.

Trusted Contributor

Re: P4000 application managed snashot SAN I/Q 9.5

Can you verify that you have dont the following?

On Windows Host/Application server, install Application Aware Snapshot Manager
Connect to Vi Center server on a host server, using Vi Client and add a new data store.
It is recommended that VMware tools is installed on the ESX server as it aids the Application Aware Snapshot process.
Ensure that you edit any virtual machines that will use Application Aware Snapshot to be Point-In-Time.

Frequent Advisor

Re: P4000 application managed snashot SAN I/Q 9.5

Hi Emilo,


If you red my post you see that i have done alll that. Installing VMware tools on ESX isn't possible. Are you sure you meant that? you cannot install VMware tools on ESX.




Re: P4000 application managed snashot SAN I/Q 9.5

I've did the same installation but I get this error when I try to create a VSS snapshot from CMC.


" A general error occurred that is not covered by a more specfic error code: Application server configuration service at not found: (401 Unautherized)" is my iSCSI IP from my ESX host??


I can ping from VC to the CMC server. (VC and CMC are both on LAN and iSCSI)

I added VC server to the CMC server list.

VC can see the "testlun".

Authentication Console on the VC give succesfull result.


What am I missing here?




New Member

Re: P4000 application managed snashot SAN I/Q 9.5

Well yes, I do have the same issue like Aart.


Same behavoir.


anything new on this thread?


thx, Steve


Re: P4000 application managed snashot SAN I/Q 9.5

Do you have any uppercase letters in CMC volumes?


It seems that with all lowercase it works.

Honored Contributor

Re: P4000 application managed snashot SAN I/Q 9.5

um... you are using as an IP? Isn't that in the public range? I've gotta assume you aren't keeping your iscsi on a public IP so that range has to cause you routing issues at some point.
Occasional Visitor

Re: P4000 application managed snashot SAN I/Q 9.5



we faced many similar issues and was solved by installing an updated version of the HP P4000 Application Aware Snapshot Manager. the updated version fixed the following bug according to our case (may be it fix other problems as well) :

if you have an NFS based data store in the VMWARE , the CMC will fail to scan that nfs volume while trying to establish the application awhich prevents the application 

pls. insure you have the latest SW in both lefthand  and server sides


good luck